summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb
new file mode 100644
index 0000000000..e09eb00ed1
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_0.9.5.bb
@@ -0,0 +1,32 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat gconf"
5PR="r2"
6
7
8SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz \
9 file://kbdconfig"
10
11S = "${WORKDIR}/matchbox-window-manager-${PV}"
12
13inherit autotools pkgconfig update-alternatives
14
15FILES_${PN} = "${bindir}/* \
16 ${datadir}/matchbox \
17 ${sysconfdir}/matchbox \
18 ${datadir}/themes/blondie/matchbox \
19 ${datadir}/themes/Default/matchbox \
20 ${datadir}/themes/MBOpus/matchbox"
21
22ALTERNATIVE_NAME = "x-session-manager"
23ALTERNATIVE_LINK = "${bindir}/x-session-manager"
24ALTERNATIVE_PATH = "${bindir}/matchbox-session"
25ALTERNATIVE_PRIORITY = "10"
26
27EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
28
29do_install_prepend() {
30 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
31}
32