summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
new file mode 100644
index 0000000000..f67e06083e
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_svn.bb
@@ -0,0 +1,42 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPL"
4DEPENDS = "virtual/libx11 libxext libxrender startup-notification expat gconf pango libxdamage libxcomposite gtk+"
5
6PV = "0.0+svnr${SRCREV}"
7PR = "r4"
8
9SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
10 "
11
12S = "${WORKDIR}/matchbox-window-manager-2"
13
14inherit autotools pkgconfig update-alternatives
15
16# Change this to x-session-manager->matchbox-session and put in
17# matchbox-session, then change this to x-window-manager to
18# matchbox-window-manager-2.
19ALTERNATIVE_NAME = "x-window-manager"
20ALTERNATIVE_LINK = "${bindir}/x-window-manager"
21ALTERNATIVE_PATH = "${bindir}/matchbox-session"
22ALTERNATIVE_PRIORITY = "10"
23
24PACKAGES =+ "libmatchbox2"
25
26FILES_libmatchbox2 = "${libdir}/*${SOLIBS}"
27
28FILES_${PN} += "${datadir}/matchbox-2 \
29 ${sysconfdir}/matchbox-2 \
30 ${datadir}/themes/*"
31
32EXTRA_OECONF = "--enable-debug \
33 --enable-simple-manager \
34 --enable-compositing-manager \
35 --enable-libmatchbox \
36 --enable-png-theme \
37 "
38
39do_install_append () {
40 cd ${D}${bindir}
41 ln -s matchbox-window-manager-2-simple matchbox-window-manager
42}