summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb
new file mode 100644
index 0000000000..c9498f7f92
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm-2/matchbox-wm-2_git.bb
@@ -0,0 +1,46 @@
1SECTION = "x11/wm"
2DESCRIPTION = "Matchbox window manager"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://matchbox/core/mb-wm.h;endline=21;md5=1b1d328a527906350ea7ce7ab1bb7564"
5
6DEPENDS = "virtual/libx11 libxext libxrender startup-notification expat gconf pango libxdamage libxcomposite gtk+"
7
8SRCREV = "18ab9c7e4ffcb066b25281172ea82947bd56cb86"
9PV = "0.1+git${SRCPV}"
10PR = "r0"
11
12SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager-2;proto=git \
13 file://fix_makefile.patch \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig update-alternatives
19
20# Change this to x-session-manager->matchbox-session and put in
21# matchbox-session, then change this to x-window-manager to
22# matchbox-window-manager-2.
23ALTERNATIVE_NAME = "x-window-manager"
24ALTERNATIVE_LINK = "${bindir}/x-window-manager"
25ALTERNATIVE_PATH = "${bindir}/matchbox-session"
26ALTERNATIVE_PRIORITY = "10"
27
28PACKAGES =+ "libmatchbox2"
29
30FILES_libmatchbox2 = "${libdir}/*${SOLIBS}"
31
32FILES_${PN} += "${datadir}/matchbox-2 \
33 ${sysconfdir}/matchbox-2 \
34 ${datadir}/themes/*"
35
36EXTRA_OECONF = "--enable-debug \
37 --enable-simple-manager \
38 --enable-compositing-manager \
39 --enable-libmatchbox \
40 --enable-png-theme \
41 "
42
43do_install_append () {
44 cd ${D}${bindir}
45 ln -s matchbox-window-manager-2-simple matchbox-window-manager
46}