summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb')
-rw-r--r--meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
new file mode 100644
index 0000000000..d7a80305e8
--- /dev/null
+++ b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
@@ -0,0 +1,39 @@
1SUMMARY = "utility functions for the Xsettings protocol"
2DESCRIPTION = "Libraries used for applications making use of the Xsettings configuration \
3setting propagation protocol. Controls setting of double click timeout, drag-and-drop \
4threshold, and default foreground and background colors for all applications running within a \
5desktop."
6HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/"
7BUGTRACKER = "http://bugzilla.yoctoproject.org/"
8SECTION = "x/libs"
9LICENSE = "MIT-style"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
11 file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
12 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
13DEPENDS = "virtual/libx11"
14
15PR = "r5"
16
17headers = "xsettings-common.h xsettings-client.h"
18
19SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/optional-dependencies/Xsettings-client-0.10.tar.gz \
20 file://MIT-style-license \
21 file://link-x11.patch;apply=yes \
22 file://disable_Os_option.patch \
23 file://obsolete_automake_macros.patch \
24"
25
26SRC_URI[md5sum] = "c14aa9db6c097e0306dac97fb7da1add"
27SRC_URI[sha256sum] = "f274a4bc969ae192994a856b7f786c6fce96bae77f96c1c2b71dd97599e06e43"
28
29S = "${WORKDIR}/Xsettings-client-0.10"
30
31inherit autotools gettext
32
33do_configure_prepend() {
34 # This package doesn't ship with its own COPYING file and
35 # autotools will install a GPLv2 one instead of the actual MIT-style license here.
36 # Add the correct license here to avoid confusion.
37 cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
38}
39