summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb')
-rw-r--r--meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
new file mode 100644
index 0000000000..ecd6d181eb
--- /dev/null
+++ b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Common code for XSETTINGS"
2HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
4SECTION = "x/libs"
5LICENSE = "MIT-style"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
7 file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
8 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
9PRIORITY = "optional"
10DEPENDS = "virtual/libx11"
11
12PR = "r3"
13
14headers = "xsettings-common.h xsettings-client.h"
15
16SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz \
17 file://MIT-style-license \
18 file://link-x11.patch;apply=yes"
19
20S = "${WORKDIR}/Xsettings-client-0.10"
21
22inherit autotools gettext
23
24do_configure_prepend() {
25 # This package doesn't ship with its own COPYING file and
26 # autotools will install a GPLv2 one instead of the actual MIT-style license here.
27 # Add the correct license here to avoid confusion.
28 cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
29}
30