summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.6.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.6.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.6.0.bb b/meta/recipes-graphics/libva/libva_2.6.0.bb
new file mode 100644
index 0000000000..d14e1911ad
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.6.0.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "git://github.com/intel/libva.git;branch=v2.6-branch"
21SRCREV = "5f693d9e603e0e83928cec67c30b6ac902d7aa85"
22S = "${WORKDIR}/git"
23
24UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
25
26DEPENDS = "libdrm virtual/mesa"
27
28inherit meson pkgconfig features_check
29
30REQUIRED_DISTRO_FEATURES = "opengl"
31
32PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
33PACKAGECONFIG[x11] = "-Dwith_x11=yes, -Dwith_x11=no,virtual/libx11 libxext libxfixes"
34PACKAGECONFIG[wayland] = "-Dwith_wayland=yes, -Dwith_wayland=no,wayland-native wayland"
35
36PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
37
38RDEPENDS_${PN}-x11 =+ "${PN}"
39RDEPENDS_${PN}-glx =+ "${PN}-x11"
40
41FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
42FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
43FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"