summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_1.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libva/libva_1.8.3.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_1.8.3.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_1.8.3.bb b/meta/recipes-graphics/libva/libva_1.8.3.bb
new file mode 100644
index 0000000000..bb5f829fcc
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_1.8.3.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/01org/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "git://github.com/01org/libva.git;protocol=http;branch=v1.8-branch "
21SRCREV = "457470987cc9df5976ce8c72ffd4bfbd9baaf0f9"
22UPSTREAM_CHECK_GITTAGREGEX = "libva-(?P<pver>(\d+(\.\d+)+))"
23
24S = "${WORKDIR}/git"
25
26DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
27
28inherit autotools pkgconfig distro_features_check
29
30REQUIRED_DISTRO_FEATURES = "opengl"
31
32EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
33
34PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
35PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
36PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
37
38PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
39
40RDEPENDS_${PN}-tpi =+ "${PN}"
41RDEPENDS_${PN}-x11 =+ "${PN}"
42RDEPENDS_${PN}-glx =+ "${PN}-x11"
43RDEPENDS_${PN}-egl =+ "${PN}-x11"
44
45FILES_${PN}-dbg += "${libdir}/dri/.debug"
46
47FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
48FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
49FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
50FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
51FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"