diff options
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.9.bb')
-rw-r--r-- | meta/recipes-graphics/libsdl2/libsdl2_2.0.9.bb | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.9.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.9.bb new file mode 100644 index 0000000000..a5ec77728a --- /dev/null +++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.9.bb | |||
@@ -0,0 +1,68 @@ | |||
1 | SUMMARY = "Simple DirectMedia Layer" | ||
2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ | ||
3 | library designed to provide low level access to audio, keyboard, mouse, \ | ||
4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." | ||
5 | HOMEPAGE = "http://www.libsdl.org" | ||
6 | BUGTRACKER = "http://bugzilla.libsdl.org/" | ||
7 | |||
8 | SECTION = "libs" | ||
9 | |||
10 | LICENSE = "Zlib" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=02ee26814dd044bd7838ae24e05b880f" | ||
12 | |||
13 | PROVIDES = "virtual/libsdl2" | ||
14 | |||
15 | SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ | ||
16 | file://more-gen-depends.patch \ | ||
17 | " | ||
18 | |||
19 | S = "${WORKDIR}/SDL2-${PV}" | ||
20 | |||
21 | SRC_URI[md5sum] = "f2ecfba915c54f7200f504d8b48a5dfe" | ||
22 | SRC_URI[sha256sum] = "255186dc676ecd0c1dbf10ec8a2cc5d6869b5079d8a38194c2aecdff54b324b1" | ||
23 | |||
24 | inherit autotools lib_package binconfig pkgconfig | ||
25 | |||
26 | EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ | ||
27 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ | ||
28 | --disable-video-dummy \ | ||
29 | --enable-pthreads \ | ||
30 | --enable-sdl-dlopen \ | ||
31 | --disable-rpath \ | ||
32 | --disable-sndio \ | ||
33 | " | ||
34 | |||
35 | # opengl packageconfig factored out to make it easy for distros | ||
36 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL | ||
37 | PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" | ||
38 | |||
39 | PACKAGECONFIG_class-native = "x11" | ||
40 | PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
41 | PACKAGECONFIG ??= " \ | ||
42 | ${PACKAGECONFIG_GL} \ | ||
43 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \ | ||
44 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ | ||
45 | " | ||
46 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," | ||
47 | PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb" | ||
48 | PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" | ||
49 | PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" | ||
50 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" | ||
51 | PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib" | ||
52 | PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon" | ||
53 | PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" | ||
54 | |||
55 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" | ||
56 | |||
57 | do_configure_prepend() { | ||
58 | # Remove old libtool macros. | ||
59 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" | ||
60 | for i in ${MACROS}; do | ||
61 | rm -f ${S}/acinclude/$i | ||
62 | done | ||
63 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR | ||
64 | } | ||
65 | |||
66 | FILES_${PN}-dev += "${libdir}/cmake" | ||
67 | |||
68 | BBCLASSEXTEND = "native nativesdk" | ||