diff options
Diffstat (limited to 'meta/recipes-graphics/libsdl2/libsdl2_2.0.7.bb')
-rw-r--r-- | meta/recipes-graphics/libsdl2/libsdl2_2.0.7.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.7.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.7.bb new file mode 100644 index 0000000000..fcbfa738b5 --- /dev/null +++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.7.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "Simple DirectMedia Layer" | ||
2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ | ||
3 | library designed to provide low level access to audio, keyboard, mouse, \ | ||
4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." | ||
5 | HOMEPAGE = "http://www.libsdl.org" | ||
6 | BUGTRACKER = "http://bugzilla.libsdl.org/" | ||
7 | |||
8 | SECTION = "libs" | ||
9 | |||
10 | LICENSE = "Zlib" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=e4688d3bd5bf02dadaa3e5182fd9eda9" | ||
12 | |||
13 | PROVIDES = "virtual/libsdl2" | ||
14 | |||
15 | DEPENDS_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}" | ||
16 | |||
17 | SRC_URI = " \ | ||
18 | http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ | ||
19 | " | ||
20 | |||
21 | S = "${WORKDIR}/SDL2-${PV}" | ||
22 | |||
23 | SRC_URI[md5sum] = "cdb071009d250e1782371049f0d5ca42" | ||
24 | SRC_URI[sha256sum] = "ee35c74c4313e2eda104b14b1b86f7db84a04eeab9430d56e001cea268bf4d5e" | ||
25 | |||
26 | inherit autotools lib_package binconfig pkgconfig | ||
27 | |||
28 | EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ | ||
29 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ | ||
30 | --disable-video-dummy \ | ||
31 | --enable-pthreads \ | ||
32 | --enable-sdl-dlopen \ | ||
33 | --disable-rpath \ | ||
34 | " | ||
35 | |||
36 | # opengl packageconfig factored out to make it easy for distros | ||
37 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL | ||
38 | PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" | ||
39 | |||
40 | PACKAGECONFIG ??= " \ | ||
41 | ${PACKAGECONFIG_GL} \ | ||
42 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \ | ||
43 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ | ||
44 | " | ||
45 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," | ||
46 | PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb" | ||
47 | PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" | ||
48 | PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" | ||
49 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" | ||
50 | PACKAGECONFIG[tslib] = "--enable-input-tslib,--disable-input-tslib,tslib" | ||
51 | PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon" | ||
52 | PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" | ||
53 | |||
54 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" | ||
55 | |||
56 | do_configure_prepend() { | ||
57 | # Remove old libtool macros. | ||
58 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" | ||
59 | for i in ${MACROS}; do | ||
60 | rm -f ${S}/acinclude/$i | ||
61 | done | ||
62 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR | ||
63 | } | ||
64 | |||
65 | FILES_${PN}-dev += "${libdir}/cmake" | ||