summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl/libsdl_1.2.15.bb')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
new file mode 100644
index 0000000000..8b394428dc
--- /dev/null
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
12
13PROVIDES = "virtual/libsdl"
14
15DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
16 ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} \
17 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \
18 tslib"
19DEPENDS_virtclass-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk', '', d)}"
20
21PR = "r0"
22
23SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
24 file://configure_tweak.patch \
25 "
26
27S = "${WORKDIR}/SDL-${PV}"
28
29SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
30SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00"
31
32inherit autotools lib_package binconfig pkgconfig
33
34EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
35 --enable-file --disable-oss --disable-esd --disable-arts \
36 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
37 --disable-mintaudio --disable-nasm --disable-video-dga \
38 --disable-video-fbcon --disable-video-ps2gs --disable-video-ps3 \
39 --disable-video-xbios --disable-video-gem --disable-video-dummy \
40 --enable-input-events --enable-input-tslib --enable-pthreads \
41 ${@base_contains('DISTRO_FEATURES', 'directfb', '--enable-video-directfb', '--disable-video-directfb', d)} \
42 ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \
43 ${@base_contains('DISTRO_FEATURES', 'x11', '--enable-video-x11', '--disable-video-x11', d)} \
44 --disable-video-svga \
45 --disable-video-picogui --disable-video-qtopia --enable-dlopen \
46 --disable-rpath \
47 --disable-pulseaudio"
48
49PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
50PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib,"
51
52PARALLEL_MAKE = ""
53
54EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
55
56do_configure_prepend() {
57 # Remove old libtool macros.
58 MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
59 for i in ${MACROS}; do
60 rm -f acinclude/$i
61 done
62 export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
63}
64
65BBCLASSEXTEND = "nativesdk"