summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libsdl/libsdl_1.2.11.bb')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
new file mode 100644
index 0000000000..7c1c507666
--- /dev/null
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.11.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Simple DirectMedia Layer"
2DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
3library designed to provide low level access to audio, keyboard, mouse, \
4joystick, 3D hardware via OpenGL, and 2D video framebuffer."
5HOMEPAGE = "http://www.libsdl.org"
6BUGTRACKER = "http://bugzilla.libsdl.org/"
7
8SECTION = "libs"
9
10LICENSE = "LGPLv2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
12
13DEPENDS = "virtual/libx11 libxext libxrandr libxrender"
14DEPENDS_virtclass-nativesdk = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
15
16PR = "r6"
17
18SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
19 file://acinclude.m4 \
20 file://configure_tweak.patch;patch=1 \
21 file://kernel-asm-page.patch;patch=1 "
22
23S = "${WORKDIR}/SDL-${PV}"
24
25SRC_URI[md5sum] = "418b42956b7cd103bfab1b9077ccc149"
26SRC_URI[sha256sum] = "6985823287b224b57390b1c1b6cbc54cc9a7d7757fbf9934ed20754b4cd23730"
27
28inherit autotools binconfig pkgconfig nativesdk
29
30EXTRA_OECONF = "--disable-static --disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
31 --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
32 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
33 --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
34 --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
35 --disable-video-xbios --disable-video-gem --disable-video-dummy \
36 --disable-video-opengl --enable-input-events --enable-pthreads \
37 --disable-video-svga \
38 --disable-video-picogui --disable-video-qtopia --enable-dlopen"
39
40PARALLEL_MAKE = ""
41
42do_configure_prepend() {
43 cp ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
44}
45
46BBCLASSEXTEND = "nativesdk"