summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb')
-rw-r--r--meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb b/meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb
new file mode 100644
index 0000000000..a1531b838e
--- /dev/null
+++ b/meta/recipes-graphics/libmatchbox/libmatchbox_1.10.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Matchbox window manager core library"
2SECTION = "x11/libs"
3HOMEPAGE = "http://matchbox-project.org/"
4BUGTRACKER = "http://bugzilla.yoctoproject.com/"
5
6LICENSE = "LGPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
8 file://libmb/mbexp.c;endline=20;md5=28c0aef3b23e308464f5dae6a11b0d2f \
9 file://libmb/mbdotdesktop.c;endline=21;md5=5a287156b3207e851c1d68d09c439b51"
10
11DEPENDS = "virtual/libx11 libxext expat libxft jpeg libpng zlib libxsettings-client startup-notification"
12
13SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/${BPN}/${PV}/${BPN}-${PV}.tar.gz \
14 file://check.m4"
15SRC_URI[md5sum] = "042c5874631dfb95151aa793dc1434b8"
16SRC_URI[sha256sum] = "d14d4844840e3e1e4faa9f9e90060915d39b6033f6979464ab3ea3fe1c4f9293"
17
18PR = "r0"
19
20inherit autotools pkgconfig
21
22S = "${WORKDIR}/libmatchbox-${PV}"
23
24do_configure_prepend () {
25 cp ${WORKDIR}/check.m4 ${S}/
26}
27
28EXTRA_OECONF = "--enable-jpeg --enable-expat --enable-xsettings --enable-startup-notification"