diff options
Diffstat (limited to 'meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb')
-rw-r--r-- | meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb | 38 |
1 files changed, 19 insertions, 19 deletions
diff --git a/meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb b/meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb index afa0ab1be6..3b8130af6d 100644 --- a/meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb +++ b/meta/recipes-graphics/jpeg/libjpeg-turbo_2.1.0.bb | |||
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8a61af33cc1c681cd5cc297150bbb | |||
7 | file://jpeglib.h;endline=16;md5=52b5eaade8d5b6a452a7693dfe52c084 \ | 7 | file://jpeglib.h;endline=16;md5=52b5eaade8d5b6a452a7693dfe52c084 \ |
8 | file://djpeg.c;endline=11;md5=b61f01ad6aff437b34d1f9e8004280a4 \ | 8 | file://djpeg.c;endline=11;md5=b61f01ad6aff437b34d1f9e8004280a4 \ |
9 | " | 9 | " |
10 | DEPENDS_append_x86-64_class-target = " nasm-native" | 10 | DEPENDS:append:x86-64:class-target = " nasm-native" |
11 | DEPENDS_append_x86_class-target = " nasm-native" | 11 | DEPENDS:append:x86:class-target = " nasm-native" |
12 | 12 | ||
13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ | 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ |
14 | file://0001-libjpeg-turbo-fix-package_qa-error.patch \ | 14 | file://0001-libjpeg-turbo-fix-package_qa-error.patch \ |
@@ -22,40 +22,40 @@ PE = "1" | |||
22 | 22 | ||
23 | # Drop-in replacement for jpeg | 23 | # Drop-in replacement for jpeg |
24 | PROVIDES = "jpeg" | 24 | PROVIDES = "jpeg" |
25 | RPROVIDES_${PN} += "jpeg" | 25 | RPROVIDES:${PN} += "jpeg" |
26 | RREPLACES_${PN} += "jpeg" | 26 | RREPLACES:${PN} += "jpeg" |
27 | RCONFLICTS_${PN} += "jpeg" | 27 | RCONFLICTS:${PN} += "jpeg" |
28 | 28 | ||
29 | inherit cmake pkgconfig | 29 | inherit cmake pkgconfig |
30 | 30 | ||
31 | export NASMENV = "--reproducible --debug-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" | 31 | export NASMENV = "--reproducible --debug-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" |
32 | 32 | ||
33 | # Add nasm-native dependency consistently for all build arches is hard | 33 | # Add nasm-native dependency consistently for all build arches is hard |
34 | EXTRA_OECMAKE_append_class-native = " -DWITH_SIMD=False" | 34 | EXTRA_OECMAKE:append:class-native = " -DWITH_SIMD=False" |
35 | EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_SIMD=False" | 35 | EXTRA_OECMAKE:append:class-nativesdk = " -DWITH_SIMD=False" |
36 | 36 | ||
37 | # Work around missing x32 ABI support | 37 | # Work around missing x32 ABI support |
38 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-DWITH_SIMD=False", "", d)}" | 38 | EXTRA_OECMAKE:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-DWITH_SIMD=False", "", d)}" |
39 | 39 | ||
40 | # Work around missing non-floating point ABI support in MIPS | 40 | # Work around missing non-floating point ABI support in MIPS |
41 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "-DWITH_SIMD=False", "", d)}" | 41 | EXTRA_OECMAKE:append:class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "-DWITH_SIMD=False", "", d)}" |
42 | 42 | ||
43 | EXTRA_OECMAKE_append_class-target_arm = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "", "-DWITH_SIMD=False", d)}" | 43 | EXTRA_OECMAKE:append:class-target:arm = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "", "-DWITH_SIMD=False", d)}" |
44 | EXTRA_OECMAKE_append_class-target_armeb = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "", "-DWITH_SIMD=False", d)}" | 44 | EXTRA_OECMAKE:append:class-target:armeb = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "", "-DWITH_SIMD=False", d)}" |
45 | 45 | ||
46 | # Provide a workaround if Altivec unit is not present in PPC | 46 | # Provide a workaround if Altivec unit is not present in PPC |
47 | EXTRA_OECMAKE_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" | 47 | EXTRA_OECMAKE:append:class-target:powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" |
48 | EXTRA_OECMAKE_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" | 48 | EXTRA_OECMAKE:append:class-target:powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" |
49 | 49 | ||
50 | DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | 50 | DEBUG_OPTIMIZATION:append:armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" |
51 | DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | 51 | DEBUG_OPTIMIZATION:append:armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" |
52 | 52 | ||
53 | PACKAGES =+ "jpeg-tools libturbojpeg" | 53 | PACKAGES =+ "jpeg-tools libturbojpeg" |
54 | 54 | ||
55 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." | 55 | DESCRIPTION:jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." |
56 | FILES_jpeg-tools = "${bindir}/*" | 56 | FILES:jpeg-tools = "${bindir}/*" |
57 | 57 | ||
58 | DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" | 58 | DESCRIPTION:libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" |
59 | FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*" | 59 | FILES:libturbojpeg = "${libdir}/libturbojpeg.so.*" |
60 | 60 | ||
61 | BBCLASSEXTEND = "native nativesdk" | 61 | BBCLASSEXTEND = "native nativesdk" |