summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/images/core-image-directfb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/images/core-image-directfb.bb')
-rw-r--r--meta/recipes-graphics/images/core-image-directfb.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/images/core-image-directfb.bb b/meta/recipes-graphics/images/core-image-directfb.bb
new file mode 100644
index 0000000000..4f47185437
--- /dev/null
+++ b/meta/recipes-graphics/images/core-image-directfb.bb
@@ -0,0 +1,20 @@
1LICENSE = "MIT"
2PR="r0"
3
4
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8inherit core-image
9
10IMAGE_INSTALL += "\
11 ${CORE_IMAGE_BASE_INSTALL} \
12 packagegroup-core-basic \
13 packagegroup-core-directfb \
14"
15
16python __anonymous () {
17 packages = d.getVar('DISTRO_FEATURES', True).split()
18 if "x11" in packages:
19 raise bb.parse.SkipPackage("FEATURE \"x11\" is in DISTRO_FEATURES, Please remove \"x11\" from DISTRO_FEATURES, use \"directfb\" instead of it\n")
20}