summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb
new file mode 100644
index 0000000000..08c8f83239
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.1.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
9
10UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
11UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
12
13SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz"
14SRC_URI[sha256sum] = "e95ee43b6bd0d3d1307e2aacf0f9c0050e5baceb21988b367b833028114aa569"
15
16inherit autotools pkgconfig lib_package gtk-doc
17
18PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
19PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo"
20PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig"
21PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype"
22PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
23PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
24PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
25
26PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
27
28LEAD_SONAME = "libharfbuzz.so"
29
30do_install_append() {
31 # If no tools are installed due to PACKAGECONFIG then this directory is
32 #still installed, so remove it to stop packaging wanings.
33 rmdir --ignore-fail-on-non-empty ${D}${bindir}
34}
35
36FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
37FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
38 ${libdir}/libharfbuzz-icu.so \
39 ${libdir}/pkgconfig/harfbuzz-icu.pc \
40"
41FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
42
43BBCLASSEXTEND = "native nativesdk"