summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb
new file mode 100644
index 0000000000..3c4a5b5a2b
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.6.8.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
9
10UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
11UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
12
13SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "c8d4f2aeed6e576bd42f9dc6def1b1ae"
15SRC_URI[sha256sum] = "6648a571a27f186e47094121f0095e1b809e918b3037c630c7f38ffad86e3035"
16
17inherit autotools pkgconfig lib_package gtk-doc
18
19PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
20PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo"
21PACKAGECONFIG[fontconfig] = "--with-fontconfig,--without-fontconfig,fontconfig"
22PACKAGECONFIG[freetype] = "--with-freetype,--without-freetype,freetype"
23PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
24PACKAGECONFIG[graphite] = "--with-graphite2,--without-graphite2,graphite2"
25PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
26
27PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
28
29LEAD_SONAME = "libharfbuzz.so"
30
31do_install_append() {
32 # If no tools are installed due to PACKAGECONFIG then this directory is
33 #still installed, so remove it to stop packaging wanings.
34 rmdir --ignore-fail-on-non-empty ${D}${bindir}
35}
36
37FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
38FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
39 ${libdir}/libharfbuzz-icu.so \
40 ${libdir}/pkgconfig/harfbuzz-icu.pc \
41"
42FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
43
44BBCLASSEXTEND = "native nativesdk"