summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.4.4.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.4.4.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.4.4.bb b/meta/recipes-graphics/freetype/freetype_2.4.4.bb
new file mode 100644
index 0000000000..661650cce7
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.4.4.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8
9LICENSE = "FreeTypeLicense | GPLv2+"
10LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=8bc1a580aeb518100d00a2dd29e68edf \
11 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
12 file://docs/GPL.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
13
14SECTION = "libs"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
19 file://no-hardcode.patch"
20
21SRC_URI[md5sum] = "b3e2b6e2f1c3e0dffa1fd2a0f848b671"
22SRC_URI[sha256sum] = "4b8281c7dc4d375c6b65d3c6f4808e488a313fab47d7be82aad2c871c8480fef"
23
24S = "${WORKDIR}/freetype-${PV}"
25
26inherit autotools pkgconfig binconfig
27
28LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
29EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
30EXTRA_OEMAKE_virtclass-native = ""
31EXTRA_OECONF = "--without-zlib"
32
33do_configure() {
34 cd builds/unix
35 libtoolize --force --copy
36 aclocal -I .
37 gnu-configize --force
38 autoconf
39 cd ${S}
40 oe_runconf
41}
42
43do_configure_virtclass-native() {
44 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
45 oe_runconf
46}
47
48do_compile_prepend() {
49 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
50}
51
52FILES_${PN} = "${libdir}/lib*${SOLIBS}"
53FILES_${PN}-dev += "${bindir}"
54
55BBCLASSEXTEND = "native"
56