summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.3.12.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.3.12.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.3.12.bb b/meta/recipes-graphics/freetype/freetype_2.3.12.bb
new file mode 100644
index 0000000000..da62ffb3b2
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.3.12.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Freetype font rendering library"
2HOMEPAGE = "http://www.freetype.org/"
3BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
4
5LICENSE = "FreeTypeLicense | GPLv2+"
6LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=8bc1a580aeb518100d00a2dd29e68edf \
7 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
8 file://docs/GPL.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
9
10SECTION = "libs"
11
12PR = "r0"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
15 file://no-hardcode.patch"
16
17S = "${WORKDIR}/freetype-${PV}"
18
19inherit autotools pkgconfig binconfig
20
21LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
22EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
23EXTRA_OEMAKE_virtclass-native = ""
24EXTRA_OECONF = "--without-zlib"
25
26do_configure() {
27 cd builds/unix
28 libtoolize --force --copy
29 aclocal -I .
30 gnu-configize --force
31 autoconf
32 cd ${S}
33 oe_runconf
34}
35
36do_configure_virtclass-native() {
37 (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
38 oe_runconf
39}
40
41do_compile_prepend() {
42 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
43}
44
45FILES_${PN} = "${libdir}/lib*${SOLIBS}"
46FILES_${PN}-dev += "${bindir}"
47
48BBCLASSEXTEND = "native"
49