summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb
new file mode 100644
index 0000000000..a058b35984
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.12.4.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1367;endline=1382;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib gperf-native"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 "
26SRC_URI[md5sum] = "4fb01fc3f41760c41c69e37cc784b658"
27SRC_URI[sha256sum] = "fd5a6a663f4c4a00e196523902626654dd0c4a78686cbc6e472f338e50fdf806"
28
29do_configure_prepend() {
30 # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280
31 rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf
32}
33
34PACKAGES =+ "fontconfig-utils"
35FILES_${PN} =+ "${datadir}/xml/*"
36FILES_fontconfig-utils = "${bindir}/*"
37
38# Work around past breakage in debian.bbclass
39RPROVIDES_fontconfig-utils = "libfontconfig-utils"
40RREPLACES_fontconfig-utils = "libfontconfig-utils"
41RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
42DEBIAN_NOAUTONAME_fontconfig-utils = "1"
43
44inherit autotools pkgconfig relative_symlinks
45
46FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
47
48# comma separated list of additional directories
49# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
50FONTCONFIG_FONT_DIRS ?= "no"
51
52EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
53
54BBCLASSEXTEND = "native"