summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb
new file mode 100644
index 0000000000..115f558eef
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.12.1.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1360;endline=1375;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 "
26SRC_URI[md5sum] = "ce55e525c37147eee14cc2de6cc09f6c"
27SRC_URI[sha256sum] = "a9f42d03949f948a3a4f762287dbc16e53a927c91a07ee64207ebd90a9e5e292"
28
29PACKAGES =+ "fontconfig-utils"
30FILES_${PN} =+ "${datadir}/xml/*"
31FILES_fontconfig-utils = "${bindir}/*"
32
33# Work around past breakage in debian.bbclass
34RPROVIDES_fontconfig-utils = "libfontconfig-utils"
35RREPLACES_fontconfig-utils = "libfontconfig-utils"
36RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
37DEBIAN_NOAUTONAME_fontconfig-utils = "1"
38
39inherit autotools pkgconfig
40
41FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
42
43# comma separated list of additional directories
44# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
45FONTCONFIG_FONT_DIRS ?= "no"
46
47EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
48
49BBCLASSEXTEND = "native"