summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
new file mode 100644
index 0000000000..7c5b4b4bf9
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1143;endline=1158;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 "
25SRC_URI[md5sum] = "e75e303b4f7756c2b16203a57ac87eba"
26SRC_URI[sha256sum] = "b6b066c7dce3f436fdc0dfbae9d36122b38094f4f53bd8dffd45e195b0540d8d"
27
28PACKAGES =+ "fontconfig-utils"
29FILES_${PN} =+ "${datadir}/xml/*"
30FILES_fontconfig-utils = "${bindir}/*"
31
32# Work around past breakage in debian.bbclass
33RPROVIDES_fontconfig-utils = "libfontconfig-utils"
34RREPLACES_fontconfig-utils = "libfontconfig-utils"
35RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
36DEBIAN_NOAUTONAME_fontconfig-utils = "1"
37
38inherit autotools pkgconfig
39
40FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
41
42EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR}"
43
44BBCLASSEXTEND = "native"