summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb
new file mode 100644
index 0000000000..268a3cbb20
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.10.1.bb
@@ -0,0 +1,90 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=dc5b39c592e47a22dbec44855988d2a0 \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1109;endline=1124;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23PR = "r0"
24
25SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
26 file://fix-pkgconfig.patch \
27 file://97_fontconfig"
28
29SRC_URI[md5sum] = "c94e380eea42f2f23ca9537035ef1899"
30SRC_URI[sha256sum] = "c3912bf909c0057e50a67f58fc1b0ae644f1ebf532a0d97864588d9599280222"
31
32PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
33FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
34FILES_fontconfig-utils = "${bindir}/*"
35FILES_${PN} =+ "${datadir}/xml/*"
36
37# Work around past breakage in debian.bbclass
38RPROVIDES_fontconfig-utils = "libfontconfig-utils"
39RREPLACES_fontconfig-utils = "libfontconfig-utils"
40RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
41DEBIAN_NOAUTONAME_fontconfig-utils = "1"
42
43PARALLEL_MAKE = ""
44
45inherit autotools pkgconfig
46
47export HASDOCBOOK="no"
48
49EXTRA_OECONF = " --disable-docs --with-arch=${HOST_ARCH} --with-default-fonts=${datadir}/fonts"
50EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
51
52# The tarball has some of the patched files as read only, which
53# patch doesn't like at all
54
55fontconfig_do_unpack() {
56 chmod -R u+rw ${S}
57}
58
59python do_unpack () {
60 bb.build.exec_func('base_do_unpack', d)
61 bb.build.exec_func('fontconfig_do_unpack', d)
62}
63
64BUILD_CFLAGS += " -I${STAGING_INCDIR}/freetype2"
65
66do_configure_append () {
67 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-case/Makefile
68 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-glyphname/Makefile
69 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-lang/Makefile
70
71 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-case/Makefile
72 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-glyphname/Makefile
73 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-lang/Makefile
74
75 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-case/Makefile
76 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-glyphname/Makefile
77 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-lang/Makefile
78
79 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-case/Makefile
80 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-glyphname/Makefile
81 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-lang/Makefile
82
83}
84
85do_install_append() {
86 install -d ${D}${sysconfdir}/default/volatiles
87 install -m 0644 ${WORKDIR}/97_fontconfig ${D}${sysconfdir}/default/volatiles
88 rmdir ${D}${localstatedir}/cache/fontconfig
89 rmdir ${D}${localstatedir}/cache/
90}