summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm/libdrm_2.4.74.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/drm/libdrm_2.4.74.bb')
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.74.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.74.bb b/meta/recipes-graphics/drm/libdrm_2.4.74.bb
new file mode 100644
index 0000000000..c67d3567d2
--- /dev/null
+++ b/meta/recipes-graphics/drm/libdrm_2.4.74.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Userspace interface to the kernel DRM services"
2DESCRIPTION = "The runtime library for accessing the kernel DRM services. DRM \
3stands for \"Direct Rendering Manager\", which is the kernel portion of the \
4\"Direct Rendering Infrastructure\" (DRI). DRI is required for many hardware \
5accelerated OpenGL drivers."
6HOMEPAGE = "http://dri.freedesktop.org"
7SECTION = "x11/base"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
10PROVIDES = "drm"
11DEPENDS = "libpthread-stubs udev libpciaccess"
12
13SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
14 file://installtests.patch \
15 file://fix_O_CLOEXEC_undeclared.patch \
16 file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \
17 "
18
19SRC_URI[md5sum] = "31964aa15bdea1a40c5941d4ce0962ee"
20SRC_URI[sha256sum] = "d80dd5a76c401f4c8756dcccd999c63d7e0a3bad258d96a829055cfd86ef840b"
21
22inherit autotools pkgconfig manpages
23
24EXTRA_OECONF += "--disable-cairo-tests \
25 --without-cunit \
26 --enable-omap-experimental-api \
27 --enable-install-test-programs \
28 --disable-valgrind \
29 "
30PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
31
32ALLOW_EMPTY_${PN}-drivers = "1"
33PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
34 ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu"
35
36RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
37 ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu"
38
39FILES_${PN}-tests = "${bindir}/*"
40FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*"
41FILES_${PN}-nouveau = "${libdir}/libdrm_nouveau.so.*"
42FILES_${PN}-omap = "${libdir}/libdrm_omap.so.*"
43FILES_${PN}-intel = "${libdir}/libdrm_intel.so.*"
44FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
45FILES_${PN}-kms = "${libdir}/libkms*.so.*"
46FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
47FILES_${PN}-amdgpu = "${libdir}/libdrm_amdgpu.so.*"