summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/cairo/cairo_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/cairo/cairo_1.16.0.bb')
-rw-r--r--meta/recipes-graphics/cairo/cairo_1.16.0.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-graphics/cairo/cairo_1.16.0.bb b/meta/recipes-graphics/cairo/cairo_1.16.0.bb
new file mode 100644
index 0000000000..3e176930cc
--- /dev/null
+++ b/meta/recipes-graphics/cairo/cairo_1.16.0.bb
@@ -0,0 +1,85 @@
1SUMMARY = "The Cairo 2D vector graphics library"
2DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
3vector-based rendering for multiple target backends. Paths consist \
4of line segments and cubic splines and can be rendered at any width \
5with various join and cap styles. All colors may be specified with \
6optional translucence (opacity/alpha) and combined using the \
7extended Porter/Duff compositing algebra as found in the X Render \
8Extension."
9HOMEPAGE = "http://cairographics.org"
10BUGTRACKER = "http://bugs.freedesktop.org"
11SECTION = "libs"
12
13LICENSE = "MPL-1 & LGPLv2.1 & GPLv3+"
14LICENSE_${PN} = "MPL-1 & LGPLv2.1"
15LICENSE_${PN}-dev = "MPL-1 & LGPLv2.1"
16LICENSE_${PN}-doc = "MPL-1 & LGPLv2.1"
17LICENSE_${PN}-gobject = "MPL-1 & LGPLv2.1"
18LICENSE_${PN}-script-interpreter = "MPL-1 & LGPLv2.1"
19LICENSE_${PN}-perf-utils = "GPLv3+"
20
21LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
22
23DEPENDS = "fontconfig glib-2.0 libpng pixman zlib"
24
25SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \
26 file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \
27 "
28
29SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552"
30SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331"
31
32inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script
33
34MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace"
35
36X11DEPENDS = "virtual/libx11 libsm libxrender libxext"
37
38PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)}"
41
42PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}"
43PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb"
44PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb"
45PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind"
46PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl"
47PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2"
48PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
49
50EXTRA_OECONF += " \
51 ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \
52 --enable-tee \
53"
54
55# We don't depend on binutils so we need to disable this
56export ac_cv_lib_bfd_bfd_openr="no"
57# Ensure we don't depend on LZO
58export ac_cv_lib_lzo2_lzo2a_decompress="no"
59
60do_install_append () {
61 rm -rf ${D}${bindir}/cairo-sphinx
62 rm -rf ${D}${libdir}/cairo/cairo-fdr*
63 rm -rf ${D}${libdir}/cairo/cairo-sphinx*
64 rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
65 rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
66}
67
68PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
69
70SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library"
71DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API."
72
73SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter"
74DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \
75CairoScript. CairoScript is used by tracing utilities to enable the ability \
76to replay rendering."
77
78DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities"
79
80FILES_${PN} = "${libdir}/libcairo.so.*"
81FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
82FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
83FILES_${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so"
84
85BBCLASSEXTEND = "native nativesdk"