diff options
Diffstat (limited to 'meta/recipes-gnome/librsvg/librsvg_2.52.2.bb')
-rw-r--r-- | meta/recipes-gnome/librsvg/librsvg_2.52.2.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.52.2.bb b/meta/recipes-gnome/librsvg/librsvg_2.52.2.bb new file mode 100644 index 0000000000..7ab8136a8d --- /dev/null +++ b/meta/recipes-gnome/librsvg/librsvg_2.52.2.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | SUMMARY = "Library for rendering SVG files" | ||
2 | DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \ | ||
3 | associated with the GNOME Project. It renders SVG files to Cairo surfaces. \ | ||
4 | Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \ | ||
5 | the screen or to generate output for printing." | ||
6 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg" | ||
7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues" | ||
8 | |||
9 | LICENSE = "LGPLv2.1+" | ||
10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ | ||
11 | " | ||
12 | |||
13 | SECTION = "x11/utils" | ||
14 | DEPENDS = "cairo gdk-pixbuf glib-2.0 libcroco libxml2 pango" | ||
15 | BBCLASSEXTEND = "native" | ||
16 | |||
17 | inherit gnomebase gtk-doc pixbufcache upstream-version-is-even gobject-introspection rust | ||
18 | |||
19 | SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \ | ||
20 | file://0001-system-deps-src-lib.rs-do-not-probe-into-harcoded-li.patch \ | ||
21 | file://0001-crossbeam-utils-check-only-the-architecture-not-the-.patch \ | ||
22 | file://0001-vendor-system-deps-sort-dependencies-before-using-th.patch \ | ||
23 | " | ||
24 | |||
25 | SRC_URI[archive.sha256sum] = "03d2887c18ffb906e1a60f97fe46a7169f69aa28d6db5d285748f3618b093427" | ||
26 | |||
27 | # librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles | ||
28 | # so we cannot use cargo class directly, but still need bits and pieces from it | ||
29 | # for cargo to be happy | ||
30 | BASEDEPENDS:append = " cargo-native" | ||
31 | |||
32 | export RUST_BACKTRACE = "full" | ||
33 | export RUSTFLAGS | ||
34 | export RUST_TARGET_PATH | ||
35 | |||
36 | export RUST_TARGET = "${HOST_SYS}" | ||
37 | |||
38 | # rust-cross writes the target linker binary into target json definition without any flags. | ||
39 | # This breaks here because the linker isn't going to work without at least knowing where | ||
40 | # the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class | ||
41 | # which supplies the needed flags. | ||
42 | do_compile:prepend() { | ||
43 | cp ${STAGING_LIBDIR_NATIVE}/rustlib/${HOST_SYS}.json ${WORKDIR} | ||
44 | cp ${STAGING_LIBDIR_NATIVE}/rustlib/${BUILD_SYS}.json ${WORKDIR} | ||
45 | sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${WORKDIR}/${HOST_SYS}.json | ||
46 | RUST_TARGET_PATH="${WORKDIR}" | ||
47 | export RUST_TARGET_PATH | ||
48 | } | ||
49 | |||
50 | # Issue only on windows | ||
51 | CVE_CHECK_WHITELIST += "CVE-2018-1000041" | ||
52 | |||
53 | CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders" | ||
54 | |||
55 | PACKAGECONFIG ??= "gdkpixbuf" | ||
56 | # The gdk-pixbuf loader | ||
57 | PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native" | ||
58 | |||
59 | do_install:append() { | ||
60 | # Loadable modules don't need .a or .la on Linux | ||
61 | rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la | ||
62 | } | ||
63 | |||
64 | PACKAGES =+ "librsvg-gtk rsvg" | ||
65 | FILES:rsvg = "${bindir}/rsvg* \ | ||
66 | ${datadir}/pixmaps/svg-viewer.svg \ | ||
67 | ${datadir}/themes" | ||
68 | FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \ | ||
69 | ${datadir}/thumbnailers/librsvg.thumbnailer" | ||
70 | RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin" | ||
71 | |||
72 | PIXBUF_PACKAGES = "librsvg-gtk" | ||