summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb')
-rw-r--r--meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
new file mode 100644
index 0000000000..9b9f191e0c
--- /dev/null
+++ b/meta/recipes-gnome/gtk-doc/gtk-doc_1.25.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3 from glib-based software and produce a set of html documentation files from them"
4HOMEPAGE = "http://www.gtk.org/gtk-doc/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase perlnative
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
18PACKAGECONFIG[working-scripts] = "--with-highlight=source-highlight,--with-highlight=no,libxslt-native xmlto-native source-highlight-native"
19
20SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
21 file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
22 "
23
24SRC_URI[archive.md5sum] = "0dc6570953112a464a409fb99258ccbc"
25SRC_URI[archive.sha256sum] = "1ea46ed400e6501f975acaafea31479cea8f32f911dca4dff036f59e6464fd42"
26
27BBCLASSEXTEND = "native"
28
29# Do not check for XML catalogs when building because that
30# information is not used for anything during build. Recipe
31# dependencies make sure we have all the right bits.
32do_configure_prepend() {
33 sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
34}
35
36FILES_${PN} += "${datadir}/sgml"
37FILES_${PN}-dev += "${libdir}/cmake"
38FILES_${PN}-doc = ""
39
40SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
41gtkdoc_makefiles_sysroot_preprocess() {
42 # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
43 # instead of libtool wrapper or running them directly
44 sed -i \
45 -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
46 ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
47}
48