diff options
Diffstat (limited to 'meta/recipes-gnome/gobject-introspection/gobject-introspection_1.60.2.bb')
-rw-r--r-- | meta/recipes-gnome/gobject-introspection/gobject-introspection_1.60.2.bb | 206 |
1 files changed, 206 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.60.2.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.60.2.bb new file mode 100644 index 0000000000..f46053f443 --- /dev/null +++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.60.2.bb | |||
@@ -0,0 +1,206 @@ | |||
1 | SUMMARY = "Middleware layer between GObject-using C libraries and language bindings" | ||
2 | HOMEPAGE = "https://wiki.gnome.org/action/show/Projects/GObjectIntrospection" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "LGPLv2+ & GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c434e8128a68bedd59b80b2ac1eb1c4a \ | ||
7 | file://tools/compiler.c;endline=20;md5=fc5007fc20022720e6c0b0cdde41fabd \ | ||
8 | file://giscanner/sourcescanner.c;endline=22;md5=194d6e0c1d00662f32d030ce44de8d39 \ | ||
9 | file://girepository/giregisteredtypeinfo.c;endline=21;md5=661847611ae6979465415f31a759ba27 \ | ||
10 | " | ||
11 | |||
12 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${@oe.utils.trim_version("${PV}", 2)}/${BPN}-${PV}.tar.xz \ | ||
13 | file://0001-Revert-an-incomplete-upstream-attempt-at-cross-compi.patch \ | ||
14 | file://0002-configure.ac-add-host-gi-gi-cross-wrapper-gi-ldd-wra.patch \ | ||
15 | file://0003-giscanner-add-use-binary-wrapper-option.patch \ | ||
16 | file://0004-giscanner-add-a-use-ldd-wrapper-option.patch \ | ||
17 | file://0005-Prefix-pkg-config-paths-with-PKG_CONFIG_SYSROOT_DIR-.patch \ | ||
18 | file://0001-giscanner-add-a-lib-dirs-envvar-option.patch \ | ||
19 | file://0001-giscanner-ignore-error-return-codes-from-ldd-wrapper.patch \ | ||
20 | file://0001-Port-cross-compilation-support-to-meson.patch \ | ||
21 | file://0001-meson.build-disable-tests-when-cross-compiling.patch \ | ||
22 | " | ||
23 | |||
24 | SRC_URI[md5sum] = "57c1c5dcf3d0a9aa73d06c2d5e6960d7" | ||
25 | SRC_URI[sha256sum] = "ffdfe2368fb2e34a547898b01aac0520d52d8627fdeb1c306559bcb503ab5e9c" | ||
26 | |||
27 | SRC_URI_append_class-native = " file://0001-Relocate-the-repository-directory-for-native-builds.patch" | ||
28 | |||
29 | inherit meson pkgconfig gtk-doc python3native qemu gobject-introspection-data upstream-version-is-even multilib_script | ||
30 | |||
31 | GTKDOC_MESON_OPTION = "gtk_doc" | ||
32 | |||
33 | MULTILIB_SCRIPTS = "${PN}:${bindir}/g-ir-annotation-tool ${PN}:${bindir}/g-ir-scanner" | ||
34 | |||
35 | DEPENDS_append = " libffi zlib glib-2.0 python3 flex-native bison-native autoconf-archive" | ||
36 | |||
37 | # target build needs qemu to run temporary introspection binaries created | ||
38 | # on the fly by g-ir-scanner and a native version of itself to run | ||
39 | # native versions of its own tools during build. | ||
40 | # Also prelink-rtld is used to find out library dependencies of introspection binaries | ||
41 | # (standard ldd doesn't work when cross-compiling). | ||
42 | DEPENDS_class-target_append = " gobject-introspection-native qemu-native prelink-native" | ||
43 | |||
44 | # needed for writing out the qemu wrapper script | ||
45 | export STAGING_DIR_HOST | ||
46 | export B | ||
47 | |||
48 | PACKAGECONFIG ?= "" | ||
49 | PACKAGECONFIG[doctool] = "-Ddoctool=true,-Ddoctool=false,python3-mako," | ||
50 | |||
51 | # Configure target build to use native tools of itself and to use a qemu wrapper | ||
52 | # and optionally to generate introspection data | ||
53 | EXTRA_OEMESON_class-target = " \ | ||
54 | -Denable-host-gi=true \ | ||
55 | -Denable-gi-cross-wrapper=${B}/g-ir-scanner-qemuwrapper \ | ||
56 | -Denable-gi-ldd-wrapper=${B}/g-ir-scanner-lddwrapper \ | ||
57 | -Dpkgconfig-sysroot-path=${PKG_CONFIG_SYSROOT_DIR} \ | ||
58 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Denable-introspection-data=true', '-Denable-introspection-data=false', d)} \ | ||
59 | ${@'-Dgir_dir_prefix=${libdir}' if d.getVar('MULTILIBS') else ''} \ | ||
60 | " | ||
61 | |||
62 | # Need to ensure ld.so.conf exists so prelink-native works | ||
63 | # both before we build and if we install from sstate | ||
64 | do_configure[prefuncs] += "gobject_introspection_preconfigure" | ||
65 | python gobject_introspection_preconfigure () { | ||
66 | oe.utils.write_ld_so_conf(d) | ||
67 | } | ||
68 | |||
69 | do_configure_prepend_class-native() { | ||
70 | # Tweak the native python scripts so that they don't refer to the | ||
71 | # full path of native python binary (the solution is taken from glib-2.0 recipe) | ||
72 | # This removes the risk of exceeding Linux kernel's shebang line limit (128 bytes) | ||
73 | sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in | ||
74 | } | ||
75 | |||
76 | do_configure_prepend_class-target() { | ||
77 | # Write out a qemu wrapper that will be given to gi-scanner so that it | ||
78 | # can run target helper binaries through that. | ||
79 | qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}" | ||
80 | cat > ${B}/g-ir-scanner-qemuwrapper << EOF | ||
81 | #!/bin/sh | ||
82 | # Use a modules directory which doesn't exist so we don't load random things | ||
83 | # which may then get deleted (or their dependencies) and potentially segfault | ||
84 | export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy | ||
85 | |||
86 | $qemu_binary "\$@" | ||
87 | if [ \$? -ne 0 ]; then | ||
88 | echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help." | ||
89 | echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )" | ||
90 | exit 1 | ||
91 | fi | ||
92 | EOF | ||
93 | chmod +x ${B}/g-ir-scanner-qemuwrapper | ||
94 | |||
95 | # Write out a wrapper for g-ir-scanner itself, which will be used when building introspection files | ||
96 | # for glib-based packages. This wrapper calls the native version of the scanner, and tells it to use | ||
97 | # a qemu wrapper for running transient target binaries produced by the scanner, and an include directory | ||
98 | # from the target sysroot. | ||
99 | cat > ${B}/g-ir-scanner-wrapper << EOF | ||
100 | #!/bin/sh | ||
101 | # This prevents g-ir-scanner from writing cache data to $HOME | ||
102 | export GI_SCANNER_DISABLE_CACHE=1 | ||
103 | |||
104 | g-ir-scanner --lib-dirs-envvar=GIR_EXTRA_LIBS_PATH --use-binary-wrapper=${STAGING_BINDIR}/g-ir-scanner-qemuwrapper --use-ldd-wrapper=${STAGING_BINDIR}/g-ir-scanner-lddwrapper --add-include-path=${STAGING_DATADIR}/gir-1.0 --add-include-path=${STAGING_LIBDIR}/gir-1.0 "\$@" | ||
105 | EOF | ||
106 | chmod +x ${B}/g-ir-scanner-wrapper | ||
107 | |||
108 | # Write out a wrapper for g-ir-compiler, which runs the target version of it through qemu. | ||
109 | # g-ir-compiler writes out the raw content of a C struct to disk, and therefore is architecture dependent. | ||
110 | cat > ${B}/g-ir-compiler-wrapper << EOF | ||
111 | #!/bin/sh | ||
112 | ${STAGING_BINDIR}/g-ir-scanner-qemuwrapper ${STAGING_BINDIR}/g-ir-compiler "\$@" | ||
113 | EOF | ||
114 | chmod +x ${B}/g-ir-compiler-wrapper | ||
115 | |||
116 | # Write out a wrapper to use instead of ldd, which does not work when a binary is built | ||
117 | # for a different architecture | ||
118 | cat > ${B}/g-ir-scanner-lddwrapper << EOF | ||
119 | #!/bin/sh | ||
120 | prelink-rtld --root=$STAGING_DIR_HOST "\$@" | ||
121 | EOF | ||
122 | chmod +x ${B}/g-ir-scanner-lddwrapper | ||
123 | |||
124 | # Also tweak the target python scripts so that they don't refer to the | ||
125 | # native version of python binary (the solution is taken from glib-2.0 recipe) | ||
126 | sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in | ||
127 | } | ||
128 | |||
129 | do_compile_prepend() { | ||
130 | # This prevents g-ir-scanner from writing cache data to $HOME | ||
131 | export GI_SCANNER_DISABLE_CACHE=1 | ||
132 | |||
133 | # Needed to run g-ir unit tests, which won't be able to find the built libraries otherwise | ||
134 | export GIR_EXTRA_LIBS_PATH=$B/.libs | ||
135 | } | ||
136 | |||
137 | # Our wrappers need to be available system-wide, because they will be used | ||
138 | # to build introspection files for all other gobject-based packages | ||
139 | do_install_append_class-target() { | ||
140 | install -d ${D}${bindir}/ | ||
141 | install ${B}/g-ir-scanner-qemuwrapper ${D}${bindir}/ | ||
142 | install ${B}/g-ir-scanner-wrapper ${D}${bindir}/ | ||
143 | install ${B}/g-ir-compiler-wrapper ${D}${bindir}/ | ||
144 | install ${B}/g-ir-scanner-lddwrapper ${D}${bindir}/ | ||
145 | } | ||
146 | |||
147 | # we need target versions of introspection tools in sysroot so that they can be run via qemu | ||
148 | # when building introspection files in other packages | ||
149 | SYSROOT_DIRS_append_class-target = " ${bindir}" | ||
150 | |||
151 | SYSROOT_PREPROCESS_FUNCS_append_class-target = " gi_binaries_sysroot_preprocess" | ||
152 | gi_binaries_sysroot_preprocess() { | ||
153 | # Tweak the binary names in the introspection pkgconfig file, so that it | ||
154 | # picks up our wrappers which do the cross-compile and qemu magic. | ||
155 | sed -i \ | ||
156 | -e "s|g_ir_scanner=.*|g_ir_scanner=${bindir}/g-ir-scanner-wrapper|" \ | ||
157 | -e "s|g_ir_compiler=.*|g_ir_compiler=${bindir}/g-ir-compiler-wrapper|" \ | ||
158 | ${SYSROOT_DESTDIR}${libdir}/pkgconfig/gobject-introspection-1.0.pc | ||
159 | } | ||
160 | |||
161 | SYSROOT_PREPROCESS_FUNCS_append = " gi_ldsoconf_sysroot_preprocess" | ||
162 | gi_ldsoconf_sysroot_preprocess () { | ||
163 | mkdir -p ${SYSROOT_DESTDIR}${bindir} | ||
164 | dest=${SYSROOT_DESTDIR}${bindir}/postinst-ldsoconf-${PN} | ||
165 | echo "#!/bin/sh" > $dest | ||
166 | echo "mkdir -p ${STAGING_DIR_TARGET}${sysconfdir}" >> $dest | ||
167 | echo "echo ${base_libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest | ||
168 | echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest | ||
169 | chmod 755 $dest | ||
170 | } | ||
171 | |||
172 | # Remove wrapper files from the package, only used for cross-compiling | ||
173 | PACKAGE_PREPROCESS_FUNCS += "gi_package_preprocess" | ||
174 | gi_package_preprocess() { | ||
175 | rm -f ${PKGD}${bindir}/g-ir-scanner-qemuwrapper | ||
176 | rm -f ${PKGD}${bindir}/g-ir-scanner-wrapper | ||
177 | rm -f ${PKGD}${bindir}/g-ir-compiler-wrapper | ||
178 | rm -f ${PKGD}${bindir}/g-ir-scanner-lddwrapper | ||
179 | } | ||
180 | |||
181 | SSTATE_SCAN_FILES += "g-ir-scanner-qemuwrapper g-ir-scanner-wrapper g-ir-compiler-wrapper g-ir-scanner-lddwrapper Gio-2.0.gir postinst-ldsoconf-${PN}" | ||
182 | |||
183 | # .typelib files are needed at runtime and so they go to the main package | ||
184 | FILES_${PN}_append = " ${libdir}/girepository-*/*.typelib" | ||
185 | |||
186 | # .gir files go to dev package, as they're needed for developing (but not for running) | ||
187 | # things that depends on introspection. | ||
188 | FILES_${PN}-dev_append = " ${datadir}/gir-*/*.gir ${libdir}/gir-*/*.gir" | ||
189 | FILES_${PN}-dev_append = " ${datadir}/gir-*/*.rnc" | ||
190 | |||
191 | # These are used by gobject-based packages | ||
192 | # to generate transient introspection binaries | ||
193 | FILES_${PN}-dev_append = " ${datadir}/gobject-introspection-1.0/gdump.c \ | ||
194 | ${datadir}/gobject-introspection-1.0/Makefile.introspection" | ||
195 | |||
196 | # These are used by dependent packages (e.g. pygobject) to build their | ||
197 | # testsuites. | ||
198 | FILES_${PN}-dev_append = " ${datadir}/gobject-introspection-1.0/tests/*.c \ | ||
199 | ${datadir}/gobject-introspection-1.0/tests/*.h" | ||
200 | |||
201 | FILES_${PN}-dbg += "${libdir}/gobject-introspection/giscanner/.debug/" | ||
202 | FILES_${PN}-staticdev += "${libdir}/gobject-introspection/giscanner/*.a" | ||
203 | |||
204 | RDEPENDS_${PN} = "python3-pickle python3-xml" | ||
205 | |||
206 | BBCLASSEXTEND = "native" | ||