summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
index f368814deb..8adede66a5 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
@@ -18,18 +18,21 @@ SRC_URI = "${GNOME_MIRROR}/${BPN}/1.48/${BPN}-${PV}.tar.xz \
18SRC_URI[md5sum] = "01301fa9019667d48e927353e08bc218" 18SRC_URI[md5sum] = "01301fa9019667d48e927353e08bc218"
19SRC_URI[sha256sum] = "fa275aaccdbfc91ec0bc9a6fd0562051acdba731e7d584b64a277fec60e75877" 19SRC_URI[sha256sum] = "fa275aaccdbfc91ec0bc9a6fd0562051acdba731e7d584b64a277fec60e75877"
20 20
21inherit autotools pkgconfig gtk-doc pythonnative qemu gobject-introspection-data 21inherit autotools pkgconfig gtk-doc python3native qemu gobject-introspection-data
22BBCLASSEXTEND = "native" 22BBCLASSEXTEND = "native"
23 23
24# necessary to let the call for python-config from configure.ac succeed 24# necessary to let the call for python-config from configure.ac succeed
25export STAGING_INCDIR 25export STAGING_INCDIR
26export STAGING_LIBDIR 26export STAGING_LIBDIR
27 27
28# autoconf macros otherwise will default to Python 2
29export PYTHON
30
28# needed for writing out the qemu wrapper script 31# needed for writing out the qemu wrapper script
29export STAGING_DIR_HOST 32export STAGING_DIR_HOST
30export B 33export B
31 34
32DEPENDS_append = " libffi zlib glib-2.0 python flex-native bison-native" 35DEPENDS_append = " libffi zlib glib-2.0 python3 flex-native bison-native"
33 36
34# target build needs qemu to run temporary introspection binaries created 37# target build needs qemu to run temporary introspection binaries created
35# on the fly by g-ir-scanner and a native version of itself to run 38# on the fly by g-ir-scanner and a native version of itself to run
@@ -44,7 +47,7 @@ do_configure_prepend_class-native() {
44 # Tweak the native python scripts so that they don't refer to the 47 # Tweak the native python scripts so that they don't refer to the
45 # full path of native python binary (the solution is taken from glib-2.0 recipe) 48 # full path of native python binary (the solution is taken from glib-2.0 recipe)
46 # This removes the risk of exceeding Linux kernel's shebang line limit (128 bytes) 49 # This removes the risk of exceeding Linux kernel's shebang line limit (128 bytes)
47 sed -i -e '1s,#!.*,#!${USRBINPATH}/env nativepython,' ${S}/tools/g-ir-tool-template.in 50 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
48} 51}
49 52
50do_configure_prepend_class-target() { 53do_configure_prepend_class-target() {
@@ -97,7 +100,7 @@ EOF
97 100
98 # Also tweak the target python scripts so that they don't refer to the 101 # Also tweak the target python scripts so that they don't refer to the
99 # native version of python binary (the solution is taken from glib-2.0 recipe) 102 # native version of python binary (the solution is taken from glib-2.0 recipe)
100 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/tools/g-ir-tool-template.in 103 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
101} 104}
102 105
103# Configure target build to use native tools of itself and to use a qemu wrapper 106# Configure target build to use native tools of itself and to use a qemu wrapper
@@ -109,7 +112,7 @@ EXTRA_OECONF_class-target += "--enable-host-gi \
109 " 112 "
110 113
111PACKAGECONFIG ?= "" 114PACKAGECONFIG ?= ""
112PACKAGECONFIG[doctool] = "--enable-doctool,--disable-doctool,python-mako," 115PACKAGECONFIG[doctool] = "--enable-doctool,--disable-doctool,python3-mako,"
113 116
114do_compile_prepend_class-target() { 117do_compile_prepend_class-target() {
115 # This prevents g-ir-scanner from writing cache data to $HOME 118 # This prevents g-ir-scanner from writing cache data to $HOME