summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb')
-rw-r--r--meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
new file mode 100644
index 0000000000..4966ea4c7a
--- /dev/null
+++ b/meta/recipes-gnome/gnome/libart-lgpl_2.3.21.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Library of functions for 2D graphics"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5PR = "r2"
6
7ART_CONFIG = "${HOST_ARCH}/art_config.h"
8
9# can't use gnome.oeclass due to _ in filename
10SRC_URI = "${GNOME_MIRROR}/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
11 file://${ART_CONFIG} \
12 file://Makefile.am.patch"
13
14SRC_URI[md5sum] = "08559ff3c67fd95d57b0c5e91a6b4302"
15SRC_URI[sha256sum] = "fdc11e74c10fc9ffe4188537e2b370c0abacca7d89021d4d303afdf7fd7476fa"
16
17inherit autotools pkgconfig
18
19DEPENDS = ""
20
21FILES_${PN} = "${libdir}/*.so.*"
22FILES_${PN}-dev += "${bindir}/libart2-config"
23
24S = "${WORKDIR}/libart_lgpl-${PV}"
25
26do_configure_prepend() {
27 cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
28}