summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb')
-rw-r--r--meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb b/meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb
new file mode 100644
index 0000000000..fa565f3d1c
--- /dev/null
+++ b/meta/recipes-gnome/gnome/libart-lgpl_2.3.19.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Library of functions for 2D graphics"
2SECTION = "x11/gnome"
3LICENSE = "LGPL"
4PR = "r1"
5
6ART_CONFIG = "${HOST_ARCH}/art_config.h"
7
8# can't use gnome.oeclass due to _ in filename
9SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
10 file://${ART_CONFIG} \
11 file://Makefile.am.patch;patch=1"
12
13inherit autotools pkgconfig
14
15DEPENDS = ""
16
17FILES_${PN} = "${libdir}/*.so.*"
18FILES_${PN}-dev += "${bindir}/libart2-config"
19
20S = "${WORKDIR}/libart_lgpl-${PV}"
21
22do_configure_prepend() {
23 cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
24}
25
26EXTRA_OECONF = "--disable-gtk-doc"
27