summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb')
-rw-r--r--meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb b/meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb
new file mode 100644
index 0000000000..f51e83e3f4
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gobject-introspection_1.32.1.bb
@@ -0,0 +1,31 @@
1# NOTE: WIP! This recipe does not cross-compile atm., only -native
2DEPENDS = "glib-2.0 libffi python-native gobject-introspection-native"
3DEPENDS_virtclass-native = "glib-2.0-native libffi-native python-native bison-native flex-native"
4BBCLASSEXTEND = "native"
5
6SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
7SRC_URI = "\
8 ${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
9 file://use-usr-bin-env-for-python.patch \
10"
11
12SRC_URI[md5sum] = "7bbdb696c37bb98aef5af02c4b8975e3"
13SRC_URI[sha256sum] = "44f3fb933f76e4728818cc360cb5f9e2edcbdf9bc8a8f9aded99b3e3ef5cb858"
14
15LICENSE = "GPLv2+ & LGPLv2+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=90d577535a3898e1ae5dbf0ae3509a8c \
17 file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7"
19
20inherit autotools
21
22do_configure_prepend () {
23 echo "EXTRA_DIST = " > ${S}/gtk-doc.make
24}
25
26EXTRA_OECONF = "\
27 --disable-gtk-doc \
28 --disable-gtk-doc-html \
29 --disable-gtk-doc-pdf \
30 --disable-tests \
31"