summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.6.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.6.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.6.bb b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
new file mode 100644
index 0000000000..a37bd009a4
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf_3.2.6.bb
@@ -0,0 +1,59 @@
1DESCRIPTION = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6POLKIT = "polkit"
7POLKIT_libc-uclibc = ""
8
9DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
10DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
11
12PR = "r0"
13
14inherit gnomebase gtk-doc
15
16SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
17 file://remove_plus_from_invalid_characters_list.patch \
18"
19
20SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
21SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
22
23S = "${WORKDIR}/GConf-${PV}"
24
25POLKIT_OECONF = "--enable-defaults-service"
26POLKIT_OECONF_class-native = "--disable-defaults-service"
27POLKIT_OECONF_libc-uclibc = "--disable-default-service"
28
29EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \
30 --disable-introspection --disable-orbit --with-openldap=no ${POLKIT_OECONF} --disable-gtk"
31
32do_install_append() {
33 # this directory need to be created to avoid an Error 256 at gdm launch
34 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
35
36 # this stuff is unusable
37 rm -f ${D}${libdir}/GConf/*/*.*a
38 rm -f ${D}${libdir}/gio/*/*.*a
39}
40
41do_install_append_class-native() {
42 create_wrapper ${D}/${bindir}/gconftool-2 \
43 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
44}
45
46# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
47RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
48RDEPENDS_${PN}_class-native = ""
49
50FILES_${PN} += "${libdir}/GConf/* \
51 ${libdir}/gio/*/*.so \
52 ${datadir}/polkit* \
53 ${datadir}/dbus-1/services/*.service \
54 ${datadir}/dbus-1/system-services/*.service \
55 "
56FILES_${PN}-dbg += "${libdir}/*/*/.debug"
57FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
58
59BBCLASSEXTEND = "native"