summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf_3.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf_3.2.5.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.5.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.5.bb b/meta/recipes-gnome/gnome/gconf_3.2.5.bb
new file mode 100644
index 0000000000..9e9232269a
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf_3.2.5.bb
@@ -0,0 +1,57 @@
1DESCRIPTION = "GNOME configuration system"
2SECTION = "x11/gnome"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6POLKIT = "polkit"
7POLKIT_libc-uclibc = ""
8
9DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
10DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
11
12PR = "r13"
13
14inherit gnomebase gtk-doc
15
16SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive"
17
18S = "${WORKDIR}/GConf-${PV}"
19
20SRC_URI[archive.md5sum] = "1b803eb4f8576c572d072692cf40c9d8"
21SRC_URI[archive.sha256sum] = "4ddea9503a212ee126c5b46a0a958fd5484574c3cb6ef2baf38db02e819e58c6"
22
23POLKIT_OECONF = "--enable-defaults-service"
24POLKIT_OECONF_class-native = "--disable-defaults-service"
25POLKIT_OECONF_libc-uclibc = "--disable-default-service"
26
27EXTRA_OECONF = "--enable-shared --disable-static --enable-debug=yes \
28 --disable-introspection --disable-orbit --with-openldap=no ${POLKIT_OECONF} --disable-gtk"
29
30do_install_append() {
31 # this directory need to be created to avoid an Error 256 at gdm launch
32 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
33
34 # this stuff is unusable
35 rm -f ${D}${libdir}/GConf/*/*.*a
36 rm -f ${D}${libdir}/gio/*/*.*a
37}
38
39do_install_append_class-native() {
40 create_wrapper ${D}/${bindir}/gconftool-2 \
41 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
42}
43
44# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
45RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
46RDEPENDS_${PN}_class-native = ""
47
48FILES_${PN} += "${libdir}/GConf/* \
49 ${libdir}/gio/*/*.so \
50 ${datadir}/polkit* \
51 ${datadir}/dbus-1/services/*.service \
52 ${datadir}/dbus-1/system-services/*.service \
53 "
54FILES_${PN}-dbg += "${libdir}/*/*/.debug"
55FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
56
57BBCLASSEXTEND = "native"