summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf-dbus_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf-dbus_svn.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf-dbus_svn.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf-dbus_svn.bb b/meta/recipes-gnome/gnome/gconf-dbus_svn.bb
new file mode 100644
index 0000000000..879a0bb558
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf-dbus_svn.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Settings daemon using DBUS for communication."
2SECTION = "x11/utils"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6DEPENDS = "intltool-native virtual/libintl glib-2.0 dbus dbus-glib libxml2 popt gtk-doc-native"
7PROVIDES = "gconf"
8RPROVIDES_${PN} = "gconf"
9RPROVIDES_${PN}-dev = "gconf-dev"
10
11PV = "2.16.0+svnr${SRCREV}"
12
13SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http"
14S = "${WORKDIR}/trunk"
15
16inherit pkgconfig autotools
17
18PARALLEL_MAKE = ""
19
20
21EXTRA_OECONF = "--disable-gtk-doc --disable-gtk --enable-shared --disable-static --enable-debug=yes"
22
23
24do_configure_prepend() {
25 touch gtk-doc.make
26}
27
28FILES_${PN} = "${libdir}/GConf-dbus/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus* ${libdir}/*.so.* ${bindir}/* ${libexecdir}/*"
29FILES_${PN}-dbg += " ${libdir}/GConf-dbus/2/.debug"
30
31BBCLASSEXTEND = "native"
32