summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gconf-dbus_705.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gconf-dbus_705.bb')
-rw-r--r--meta/recipes-gnome/gnome/gconf-dbus_705.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/gconf-dbus_705.bb b/meta/recipes-gnome/gnome/gconf-dbus_705.bb
new file mode 100644
index 0000000000..fdfc45f5b3
--- /dev/null
+++ b/meta/recipes-gnome/gnome/gconf-dbus_705.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = "Settings daemon using DBUS for communication."
2SECTION = "x11/utils"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
5
6DEPENDS = "intltool-native virtual/libintl glib-2.0 dbus dbus-glib libxml2 popt gtk-doc-native"
7PROVIDES = "gconf"
8RPROVIDES_${PN} = "gconf"
9RPROVIDES_${PN}-dev = "gconf-dev"
10
11#SRCREV = "705"
12#PV = "2.16.0+svnr${SRCPV}"
13PR = "r0"
14
15# This SVN repo is no longer available use a tarball mirror site until
16# we move to proper gconf recipe.
17#SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http"
18SRC_URI = "http://autobuilder.pokylinux.org/sources/trunk_developer.imendio.com_.svn.gconf-dbus_705_.tar.gz"
19
20S = "${WORKDIR}/trunk"
21
22inherit pkgconfig autotools
23
24PARALLEL_MAKE = ""
25
26
27EXTRA_OECONF = "--disable-gtk-doc --disable-gtk --enable-shared --disable-static --enable-debug=yes"
28
29
30do_configure_prepend() {
31 touch gtk-doc.make
32}
33
34FILES_${PN} = "${libdir}/GConf-dbus/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus* ${libdir}/*.so.* ${bindir}/* ${libexecdir}/*"
35FILES_${PN}-dbg += " ${libdir}/GConf-dbus/2/.debug"
36
37BBCLASSEXTEND = "native"
38