summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb')
-rw-r--r--meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb
new file mode 100644
index 0000000000..2052761714
--- /dev/null
+++ b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.18.0.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GTK+ icon theme"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/adwaita-icon-theme/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-3.0 | CC-BY-SA-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c"
8
9inherit allarch autotools pkgconfig gettext gtk-icon-cache
10
11DEPENDS += "intltool-native"
12
13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
15 "
16
17SRC_URI[md5sum] = "ec1fa3fde83ad166ae7075a97dc1ec4b"
18SRC_URI[sha256sum] = "5e9ce726001fdd8ee93c394fdc3cdb9e1603bbed5b7c62df453ccf521ec50e58"
19
20do_install_append() {
21 # Build uses gtk-encode-symbolic-svg to create png versions:
22 # no need to store the svgs anymore.
23 rm -f ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic.svg \
24 ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic-rtl.svg
25}
26
27PACKAGES = "${PN}-cursors ${PN}-symbolic ${PN}-hires ${PN}"
28
29RREPLACES_${PN} = "gnome-icon-theme"
30RCONFLICTS_${PN} = "gnome-icon-theme"
31RPROVIDES_${PN} = "gnome-icon-theme"
32
33FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/"
34FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/*/*/*.symbolic.png"
35FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/"
36FILES_${PN} = "${prefix}/share/icons/Adwaita/ \
37 ${prefix}/share/pkgconfig/adwaita-icon-theme.pc"