summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb')
-rw-r--r--meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb
new file mode 100644
index 0000000000..526e699e99
--- /dev/null
+++ b/meta/recipes-gnome/gnome/adwaita-icon-theme_3.16.2.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "GTK+ icon theme"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/adwaita-icon-theme/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-3.0 | CC-BY-SA-3.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c84cac88e46fc07647ea07e6c24eeb7c"
8
9inherit allarch autotools pkgconfig gettext gtk-icon-cache
10
11DEPENDS += "intltool-native"
12
13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
15 file://Create-symlinks-when-installing-cursors.patch \
16 "
17
18SRC_URI[md5sum] = "9ef86952c947aa27a1a888b7735d60b3"
19SRC_URI[sha256sum] = "b4556dfbf555d4fac12d4d5c12f7519de0d43ec42a1b649611439a50bf7acb96"
20
21do_install_append() {
22 # Build uses gtk-encode-symbolic-svg to create png versions:
23 # no need to store the svgs anymore.
24 rm -f ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic.svg \
25 ${D}${prefix}/share/icons/Adwaita/scalable/*/*-symbolic-rtl.svg
26}
27
28PACKAGES = "${PN}-cursors ${PN}-symbolic ${PN}-hires ${PN}"
29
30FILES_${PN}-cursors = "${prefix}/share/icons/Adwaita/cursors/"
31FILES_${PN}-symbolic = "${prefix}/share/icons/Adwaita/*/*/*.symbolic.png"
32FILES_${PN}-hires = "${prefix}/share/icons/Adwaita/256x256/"
33FILES_${PN} = "${prefix}/share/icons/Adwaita/ \
34 ${prefix}/share/pkgconfig/adwaita-icon-theme.pc"