diff options
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.42.6.bb')
-rw-r--r-- | meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.42.6.bb | 123 |
1 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.42.6.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.42.6.bb new file mode 100644 index 0000000000..2734a11f96 --- /dev/null +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.42.6.bb | |||
@@ -0,0 +1,123 @@ | |||
1 | SUMMARY = "Image loading library for GTK+" | ||
2 | DESCRIPTION = "The GDK Pixbuf library provides: Image loading and saving \ | ||
3 | facilities, fast scaling and compositing of pixbufs and Simple animation \ | ||
4 | loading (ie. animated GIFs)" | ||
5 | HOMEPAGE = "https://wiki.gnome.org/Projects/GdkPixbuf" | ||
6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gdk-pixbuf/issues" | ||
7 | |||
8 | LICENSE = "LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ | ||
10 | file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=72b39da7cbdde2e665329fef618e1d6b \ | ||
11 | " | ||
12 | |||
13 | SECTION = "libs" | ||
14 | |||
15 | DEPENDS = "glib-2.0 gdk-pixbuf-native shared-mime-info" | ||
16 | DEPENDS_remove_class-native = "gdk-pixbuf-native" | ||
17 | |||
18 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
19 | |||
20 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ | ||
21 | file://run-ptest \ | ||
22 | file://fatal-loader.patch \ | ||
23 | file://0001-Work-around-thumbnailer-cross-compile-failure.patch \ | ||
24 | file://0001-Fix-a-couple-of-decisions-around-cross-compilation.patch \ | ||
25 | file://0006-Build-thumbnailer-and-tests-also-in-cross-builds.patch \ | ||
26 | file://0001-Work-around-thumbnailer-and-pixdata-cross-compile-fa.patch \ | ||
27 | " | ||
28 | |||
29 | SRC_URI[sha256sum] = "c4a6b75b7ed8f58ca48da830b9fa00ed96d668d3ab4b1f723dcf902f78bde77f" | ||
30 | |||
31 | inherit meson pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc lib_package | ||
32 | |||
33 | GIR_MESON_OPTION = 'introspection' | ||
34 | GIR_MESON_ENABLE_FLAG = "enabled" | ||
35 | GIR_MESON_DISABLE_FLAG = "disabled" | ||
36 | |||
37 | LIBV = "2.10.0" | ||
38 | |||
39 | GDK_PIXBUF_LOADERS ?= "png jpeg" | ||
40 | |||
41 | PACKAGECONFIG = "${GDK_PIXBUF_LOADERS} \ | ||
42 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" | ||
43 | PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}" | ||
44 | |||
45 | PACKAGECONFIG[png] = "-Dpng=true,-Dpng=false,libpng" | ||
46 | PACKAGECONFIG[jpeg] = "-Djpeg=true,-Djpeg=false,jpeg" | ||
47 | PACKAGECONFIG[tiff] = "-Dtiff=true,-Dtiff=false,tiff" | ||
48 | PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false" | ||
49 | |||
50 | PACKAGES =+ "${PN}-xlib" | ||
51 | |||
52 | # For GIO image type sniffing | ||
53 | RDEPENDS_${PN} = "shared-mime-info" | ||
54 | |||
55 | FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}" | ||
56 | ALLOW_EMPTY_${PN}-xlib = "1" | ||
57 | |||
58 | FILES_${PN} += "${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders" | ||
59 | |||
60 | FILES_${PN}-bin += "${datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer" | ||
61 | |||
62 | FILES_${PN}-dev += " \ | ||
63 | ${bindir}/gdk-pixbuf-csource \ | ||
64 | ${bindir}/gdk-pixbuf-pixdata \ | ||
65 | ${bindir}/gdk-pixbuf-print-mime-types \ | ||
66 | ${includedir}/* \ | ||
67 | ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \ | ||
68 | " | ||
69 | |||
70 | PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*" | ||
71 | PACKAGES_DYNAMIC_class-native = "" | ||
72 | |||
73 | python populate_packages_prepend () { | ||
74 | postinst_pixbufloader = d.getVar("postinst_pixbufloader") | ||
75 | |||
76 | loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders') | ||
77 | |||
78 | packages = ' '.join(do_split_packages(d, loaders_root, r'^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s')) | ||
79 | d.setVar('PIXBUF_PACKAGES', packages) | ||
80 | |||
81 | # The test suite exercises all the loaders, so ensure they are all | ||
82 | # dependencies of the ptest package. | ||
83 | d.appendVar("RDEPENDS_%s-ptest" % d.getVar('PN'), " " + packages) | ||
84 | } | ||
85 | |||
86 | do_install_append() { | ||
87 | # Copy gdk-pixbuf-query-loaders into libdir so it is always available | ||
88 | # in multilib builds. | ||
89 | cp ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/ | ||
90 | |||
91 | } | ||
92 | |||
93 | # Remove a bad fuzzing attempt that sporadically fails without a way to reproduce | ||
94 | do_install_ptest() { | ||
95 | rm ${D}/${datadir}/installed-tests/gdk-pixbuf/pixbuf-randomly-modified.test | ||
96 | } | ||
97 | |||
98 | do_install_append_class-native() { | ||
99 | find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \; | ||
100 | |||
101 | create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \ | ||
102 | XDG_DATA_DIRS=${STAGING_DATADIR} \ | ||
103 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
104 | |||
105 | create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \ | ||
106 | XDG_DATA_DIRS=${STAGING_DATADIR} \ | ||
107 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
108 | |||
109 | create_wrapper ${D}/${bindir}/gdk-pixbuf-print-mime-types \ | ||
110 | XDG_DATA_DIRS=${STAGING_DATADIR} \ | ||
111 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
112 | |||
113 | create_wrapper ${D}/${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders \ | ||
114 | XDG_DATA_DIRS=${STAGING_DATADIR} \ | ||
115 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \ | ||
116 | GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders | ||
117 | |||
118 | create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \ | ||
119 | XDG_DATA_DIRS=${STAGING_DATADIR} \ | ||
120 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \ | ||
121 | GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders | ||
122 | } | ||
123 | BBCLASSEXTEND = "native nativesdk" | ||