summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb133
1 files changed, 0 insertions, 133 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
deleted file mode 100644
index 16708fd581..0000000000
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
+++ /dev/null
@@ -1,133 +0,0 @@
1SUMMARY = "Image loading library for GTK+"
2DESCRIPTION = "The GDK Pixbuf library provides: Image loading and saving \
3facilities, fast scaling and compositing of pixbufs and Simple animation \
4loading (ie. animated GIFs)"
5HOMEPAGE = "https://wiki.gnome.org/Projects/GdkPixbuf"
6BUGTRACKER = "https://gitlab.gnome.org/GNOME/gdk-pixbuf/issues"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
10 file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=72b39da7cbdde2e665329fef618e1d6b \
11 "
12
13SECTION = "libs"
14
15DEPENDS = "glib-2.0 gdk-pixbuf-native shared-mime-info"
16
17MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
18
19SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
20 file://run-ptest \
21 file://fatal-loader.patch \
22 file://0001-Work-around-thumbnailer-cross-compile-failure.patch \
23 file://0001-Fix-a-couple-of-decisions-around-cross-compilation.patch \
24 file://0004-Do-not-run-tests-when-building.patch \
25 file://0006-Build-thumbnailer-and-tests-also-in-cross-builds.patch \
26 file://missing-test-data.patch \
27 file://CVE-2020-29385.patch \
28 "
29
30SRC_URI_append_class-target = " \
31 file://0003-target-only-Work-around-thumbnailer-cross-compile-fa.patch \
32 "
33SRC_URI_append_class-nativesdk = " \
34 file://0003-target-only-Work-around-thumbnailer-cross-compile-fa.patch \
35 "
36
37SRC_URI[md5sum] = "05eb1ebc258ba905f1c8644ef49de064"
38SRC_URI[sha256sum] = "1582595099537ca8ff3b99c6804350b4c058bb8ad67411bbaae024ee7cead4e6"
39
40inherit meson pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc lib_package
41
42GIR_MESON_OPTION = 'gir'
43
44LIBV = "2.10.0"
45
46GDK_PIXBUF_LOADERS ?= "png jpeg"
47
48PACKAGECONFIG = "${GDK_PIXBUF_LOADERS} \
49 ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
50 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
51PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}"
52
53PACKAGECONFIG[png] = "-Dpng=true,-Dpng=false,libpng"
54PACKAGECONFIG[jpeg] = "-Djpeg=true,-Djpeg=false,jpeg"
55PACKAGECONFIG[tiff] = "-Dtiff=true,-Dtiff=false,tiff"
56PACKAGECONFIG[jpeg2000] = "-Djasper=true,-Djasper=false,jasper"
57PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false"
58PACKAGECONFIG[x11] = "-Dx11=true,-Dx11=false,virtual/libx11"
59
60PACKAGES =+ "${PN}-xlib"
61
62# For GIO image type sniffing
63RDEPENDS_${PN} = "shared-mime-info"
64
65FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}"
66ALLOW_EMPTY_${PN}-xlib = "1"
67
68FILES_${PN} += "${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
69
70FILES_${PN}-bin += "${datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer"
71
72FILES_${PN}-dev += " \
73 ${bindir}/gdk-pixbuf-csource \
74 ${bindir}/gdk-pixbuf-pixdata \
75 ${bindir}/gdk-pixbuf-print-mime-types \
76 ${includedir}/* \
77 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \
78"
79
80PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*"
81PACKAGES_DYNAMIC_class-native = ""
82
83python populate_packages_prepend () {
84 postinst_pixbufloader = d.getVar("postinst_pixbufloader")
85
86 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders')
87
88 packages = ' '.join(do_split_packages(d, loaders_root, r'^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))
89 d.setVar('PIXBUF_PACKAGES', packages)
90
91 # The test suite exercises all the loaders, so ensure they are all
92 # dependencies of the ptest package.
93 d.appendVar("RDEPENDS_%s-ptest" % d.getVar('PN'), " " + packages)
94}
95
96do_install_append() {
97 # Copy gdk-pixbuf-query-loaders into libdir so it is always available
98 # in multilib builds.
99 cp ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/
100
101}
102
103# Remove a bad fuzzing attempt that sporadically fails without a way to reproduce
104do_install_ptest() {
105 rm ${D}/${datadir}/installed-tests/gdk-pixbuf/pixbuf-randomly-modified.test
106}
107
108do_install_append_class-native() {
109 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
110
111 create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \
112 XDG_DATA_DIRS=${STAGING_DATADIR} \
113 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
114
115 create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \
116 XDG_DATA_DIRS=${STAGING_DATADIR} \
117 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
118
119 create_wrapper ${D}/${bindir}/gdk-pixbuf-print-mime-types \
120 XDG_DATA_DIRS=${STAGING_DATADIR} \
121 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
122
123 create_wrapper ${D}/${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders \
124 XDG_DATA_DIRS=${STAGING_DATADIR} \
125 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
126 GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders
127
128 create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \
129 XDG_DATA_DIRS=${STAGING_DATADIR} \
130 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
131 GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders
132}
133BBCLASSEXTEND = "native nativesdk"