summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb47
1 files changed, 38 insertions, 9 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb
index a7d3884d1f..5f081fbb94 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.11.bb
@@ -13,18 +13,42 @@ DEPENDS = "glib-2.0 gdk-pixbuf-native shared-mime-info"
13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" 13MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
14 14
15SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ 15SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
16 file://hardcoded_libtool.patch \
17 file://extending-libinstall-dependencies.patch \
18 file://run-ptest \ 16 file://run-ptest \
19 file://fatal-loader.patch \ 17 file://fatal-loader.patch \
20 file://0001-Work-around-thumbnailer-cross-compile-failure.patch \ 18 file://0001-Work-around-thumbnailer-cross-compile-failure.patch \
21 file://0001-Fix-without-libtiff-not-having-an-effect.patch \ 19 file://0001-Fix-a-couple-of-decisions-around-cross-compilation.patch \
20 file://0001-loaders.cache-depend-on-loaders-being-fully-build.patch \
21 "
22
23SRC_URI_append_class-target = " \
24 file://0002-Work-around-thumbnailer-cross-compile-failure.patch \
25 "
26SRC_URI_append_class-nativesdk = " \
27 file://0002-Work-around-thumbnailer-cross-compile-failure.patch \
28 file://0001-Disable-tests-in-native-builds.patch \
29 "
30SRC_URI_append_class-native = " \
31 file://0001-Disable-tests-in-native-builds.patch \
22 " 32 "
23 33
24SRC_URI[md5sum] = "6e84e5485c17ce7c25df77fe76eb2d6a" 34SRC_URI[md5sum] = "6e84e5485c17ce7c25df77fe76eb2d6a"
25SRC_URI[sha256sum] = "ae62ab87250413156ed72ef756347b10208c00e76b222d82d9ed361ed9dde2f3" 35SRC_URI[sha256sum] = "ae62ab87250413156ed72ef756347b10208c00e76b222d82d9ed361ed9dde2f3"
26 36
27inherit autotools pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc lib_package 37inherit meson pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc lib_package
38
39GTKDOC_ENABLE_FLAG = "-Dwith_docs=true"
40GTKDOC_DISABLE_FLAG = "-Dwith_docs=false"
41
42GI_ENABLE_FLAG = "-Dwith_gir=true"
43GI_DISABLE_FLAG = "-Dwith_gir=false"
44
45EXTRA_OEMESON_append_class-nativesdk = " ${GI_DISABLE_FLAG}"
46
47EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
48 '${GI_DISABLE_FLAG}', d)} "
49
50EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
51 '${GTKDOC_DISABLE_FLAG}', d)} "
28 52
29LIBV = "2.10.0" 53LIBV = "2.10.0"
30 54
@@ -34,12 +58,12 @@ PACKAGECONFIG ??= "${GDK_PIXBUF_LOADERS}"
34PACKAGECONFIG_linuxstdbase = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} ${GDK_PIXBUF_LOADERS}" 58PACKAGECONFIG_linuxstdbase = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} ${GDK_PIXBUF_LOADERS}"
35PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}" 59PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}"
36 60
37PACKAGECONFIG[png] = "--with-libpng,--without-libpng,libpng" 61PACKAGECONFIG[png] = "-Denable_png=true,-Denable_png=false,libpng"
38PACKAGECONFIG[jpeg] = "--with-libjpeg,--without-libjpeg,jpeg" 62PACKAGECONFIG[jpeg] = "-Denable_jpeg=true,-Denable_jpeg=false,jpeg"
39PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff" 63PACKAGECONFIG[tiff] = "-Denable_tiff=true,-Denable_tiff=false,tiff"
40PACKAGECONFIG[jpeg2000] = "--with-libjasper,--without-libjasper,jasper" 64PACKAGECONFIG[jpeg2000] = "-Denable_jasper=true,-Denable_jasper=false,jasper"
41 65
42PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11" 66PACKAGECONFIG[x11] = ",,virtual/libx11"
43 67
44PACKAGES =+ "${PN}-xlib" 68PACKAGES =+ "${PN}-xlib"
45 69
@@ -81,6 +105,11 @@ do_install_append() {
81 # Move gdk-pixbuf-query-loaders into libdir so it is always available 105 # Move gdk-pixbuf-query-loaders into libdir so it is always available
82 # in multilib builds. 106 # in multilib builds.
83 mv ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/ 107 mv ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/
108
109 # Do not install ptests if ptest is not enabled; gdk-pixbuf has no configuration option for this
110 if [ "${PTEST_ENABLED}" != "1" ]; then
111 rm -rf ${D}${datadir}/installed-tests
112 fi
84} 113}
85 114
86do_install_append_class-native() { 115do_install_append_class-native() {