diff options
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.0.bb')
-rw-r--r-- | meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.0.bb | 102 |
1 files changed, 102 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.0.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.0.bb new file mode 100644 index 0000000000..a5ebecaff3 --- /dev/null +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.36.0.bb | |||
@@ -0,0 +1,102 @@ | |||
1 | SUMMARY = "Image loading library for GTK+" | ||
2 | HOMEPAGE = "http://www.gtk.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
4 | |||
5 | LICENSE = "LGPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ | ||
7 | file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=72b39da7cbdde2e665329fef618e1d6b" | ||
8 | |||
9 | SECTION = "libs" | ||
10 | |||
11 | DEPENDS = "glib-2.0" | ||
12 | |||
13 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
14 | |||
15 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ | ||
16 | file://hardcoded_libtool.patch \ | ||
17 | file://extending-libinstall-dependencies.patch \ | ||
18 | file://run-ptest \ | ||
19 | file://fatal-loader.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "1a3baf91956c7923dab49ee3de100ce1" | ||
23 | SRC_URI[sha256sum] = "85ab52ce9f2c26327141b3dcf21cca3da6a3f8de84b95fa1e727d8871a23245c" | ||
24 | |||
25 | inherit autotools pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc | ||
26 | |||
27 | LIBV = "2.10.0" | ||
28 | |||
29 | GDK_PIXBUF_LOADERS ?= "png jpeg" | ||
30 | |||
31 | PACKAGECONFIG ??= "${GDK_PIXBUF_LOADERS}" | ||
32 | PACKAGECONFIG_linuxstdbase = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} ${GDK_PIXBUF_LOADERS}" | ||
33 | PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}" | ||
34 | |||
35 | PACKAGECONFIG[png] = "--with-libpng,--without-libpng,libpng" | ||
36 | PACKAGECONFIG[jpeg] = "--with-libjpeg,--without-libjpeg,jpeg" | ||
37 | PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff" | ||
38 | PACKAGECONFIG[jpeg2000] = "--with-libjasper,--without-libjasper,jasper" | ||
39 | |||
40 | # Use GIO to sniff image format instead of trying all loaders | ||
41 | PACKAGECONFIG[gio-sniff] = "--enable-gio-sniffing,--disable-gio-sniffing,,shared-mime-info" | ||
42 | PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11" | ||
43 | |||
44 | PACKAGES =+ "${PN}-xlib" | ||
45 | |||
46 | FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}" | ||
47 | ALLOW_EMPTY_${PN}-xlib = "1" | ||
48 | |||
49 | FILES_${PN} += "${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders" | ||
50 | |||
51 | FILES_${PN}-dev += " \ | ||
52 | ${bindir}/gdk-pixbuf-csource \ | ||
53 | ${bindir}/gdk-pixbuf-pixdata \ | ||
54 | ${includedir}/* \ | ||
55 | ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \ | ||
56 | " | ||
57 | |||
58 | PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*" | ||
59 | PACKAGES_DYNAMIC_class-native = "" | ||
60 | |||
61 | python populate_packages_prepend () { | ||
62 | postinst_pixbufloader = d.getVar("postinst_pixbufloader", True) | ||
63 | |||
64 | loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders') | ||
65 | |||
66 | packages = ' '.join(do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s')) | ||
67 | d.setVar('PIXBUF_PACKAGES', packages) | ||
68 | |||
69 | # The test suite exercises all the loaders, so ensure they are all | ||
70 | # dependencies of the ptest package. | ||
71 | d.appendVar("RDEPENDS_gdk-pixbuf-ptest", " " + packages) | ||
72 | } | ||
73 | |||
74 | do_install_append() { | ||
75 | # Move gdk-pixbuf-query-loaders into libdir so it is always available | ||
76 | # in multilib builds. | ||
77 | mv ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/ | ||
78 | } | ||
79 | |||
80 | do_install_append_class-native() { | ||
81 | find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \; | ||
82 | |||
83 | create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \ | ||
84 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
85 | |||
86 | create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \ | ||
87 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
88 | |||
89 | create_wrapper ${D}/${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders \ | ||
90 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \ | ||
91 | GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders | ||
92 | } | ||
93 | BBCLASSEXTEND = "native" | ||
94 | |||
95 | SSTATEPREINSTFUNCS_append_class-native = " gdkpixbuf_sstate_preinst" | ||
96 | SYSROOT_PREPROCESS_FUNCS_append_class-native = " gdkpixbuf_sstate_preinst" | ||
97 | |||
98 | gdkpixbuf_sstate_preinst() { | ||
99 | if [ "${BB_CURRENTTASK}" = "populate_sysroot" ]; then | ||
100 | rm -rf ${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/* | ||
101 | fi | ||
102 | } | ||