diff options
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb')
-rw-r--r-- | meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb | 86 |
1 files changed, 86 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb new file mode 100644 index 0000000000..dd1f27f6b5 --- /dev/null +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb | |||
@@ -0,0 +1,86 @@ | |||
1 | SUMMARY = "Image loading library for GTK+" | ||
2 | HOMEPAGE = "http://www.gtk.org/" | ||
3 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
4 | |||
5 | LICENSE = "LGPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ | ||
7 | file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=5066b71daefeff678494fffa3040aba9" | ||
8 | |||
9 | SECTION = "libs" | ||
10 | |||
11 | DEPENDS = "libpng glib-2.0 jpeg" | ||
12 | DEPENDS_append_linuxstdbase = " virtual/libx11" | ||
13 | |||
14 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
15 | |||
16 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ | ||
17 | file://hardcoded_libtool.patch \ | ||
18 | file://configure_fix.patch \ | ||
19 | file://extending-libinstall-dependencies.patch \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[md5sum] = "81161cc895eb43afd9ae7354b87e2261" | ||
23 | SRC_URI[sha256sum] = "c229c53f59573eab9410b53690a4b9db770312c80a4d84ecd6295aa894574494" | ||
24 | |||
25 | inherit autotools pkgconfig gettext pixbufcache | ||
26 | |||
27 | LIBV = "2.10.0" | ||
28 | |||
29 | PACKAGECONFIG ??= "" | ||
30 | PACKAGECONFIG_linuxstdbase = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" | ||
31 | PACKAGECONFIG_class-native = "" | ||
32 | PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11" | ||
33 | |||
34 | EXTRA_OECONF = "\ | ||
35 | --with-libpng \ | ||
36 | --with-libjpeg \ | ||
37 | --without-libtiff \ | ||
38 | --without-libjasper \ | ||
39 | --disable-introspection \ | ||
40 | " | ||
41 | |||
42 | PACKAGES =+ "${PN}-xlib" | ||
43 | |||
44 | FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}" | ||
45 | ALLOW_EMPTY_${PN}-xlib = "1" | ||
46 | |||
47 | FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \ | ||
48 | ${bindir}/gdk-pixbuf-pixdata \ | ||
49 | ${libdir}/lib*.so.*" | ||
50 | |||
51 | FILES_${PN}-dev += " \ | ||
52 | ${bindir}/gdk-pixbuf-csource \ | ||
53 | ${includedir}/* \ | ||
54 | ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \ | ||
55 | " | ||
56 | |||
57 | FILES_${PN}-dbg += " \ | ||
58 | ${libdir}/.debug/* \ | ||
59 | ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/.debug/* \ | ||
60 | " | ||
61 | |||
62 | PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*" | ||
63 | PACKAGES_DYNAMIC_class-native = "" | ||
64 | |||
65 | python populate_packages_prepend () { | ||
66 | postinst_pixbufloader = d.getVar("postinst_pixbufloader", True) | ||
67 | |||
68 | loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders') | ||
69 | |||
70 | d.setVar('PIXBUF_PACKAGES', ' '.join(do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))) | ||
71 | } | ||
72 | |||
73 | do_install_append_class-native() { | ||
74 | find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \; | ||
75 | |||
76 | create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \ | ||
77 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
78 | |||
79 | create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \ | ||
80 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache | ||
81 | |||
82 | create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \ | ||
83 | GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \ | ||
84 | GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders | ||
85 | } | ||
86 | BBCLASSEXTEND = "native" | ||