summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
index 187af46a99..85a7b439de 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
@@ -16,12 +16,14 @@ MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \ 16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
17 file://hardcoded_libtool.patch \ 17 file://hardcoded_libtool.patch \
18 file://extending-libinstall-dependencies.patch \ 18 file://extending-libinstall-dependencies.patch \
19 file://run-ptest \
20 file://tests-check.patch \
19 " 21 "
20 22
21SRC_URI[md5sum] = "81161cc895eb43afd9ae7354b87e2261" 23SRC_URI[md5sum] = "81161cc895eb43afd9ae7354b87e2261"
22SRC_URI[sha256sum] = "c229c53f59573eab9410b53690a4b9db770312c80a4d84ecd6295aa894574494" 24SRC_URI[sha256sum] = "c229c53f59573eab9410b53690a4b9db770312c80a4d84ecd6295aa894574494"
23 25
24inherit autotools pkgconfig gettext pixbufcache 26inherit autotools pkgconfig gettext pixbufcache ptest
25 27
26LIBV = "2.10.0" 28LIBV = "2.10.0"
27 29
@@ -42,6 +44,7 @@ PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11"
42 44
43EXTRA_OECONF = "\ 45EXTRA_OECONF = "\
44 --disable-introspection \ 46 --disable-introspection \
47 ${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-installed-tests', '--disable-installed-tests', d)} \
45" 48"
46 49
47PACKAGES =+ "${PN}-xlib" 50PACKAGES =+ "${PN}-xlib"
@@ -64,6 +67,11 @@ FILES_${PN}-dbg += " \
64 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/.debug/* \ 67 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/.debug/* \
65" 68"
66 69
70FILES_${PN}-ptest += "${libdir}/gdk-pixbuf/installed-tests \
71 ${datadir}/installed-tests/gdk-pixbuf"
72
73RDEPENDS_${PN}-ptest += "gnome-desktop-testing"
74
67PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*" 75PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*"
68PACKAGES_DYNAMIC_class-native = "" 76PACKAGES_DYNAMIC_class-native = ""
69 77
@@ -72,7 +80,12 @@ python populate_packages_prepend () {
72 80
73 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders') 81 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders')
74 82
75 d.setVar('PIXBUF_PACKAGES', ' '.join(do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))) 83 packages = ' '.join(do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))
84 d.setVar('PIXBUF_PACKAGES', packages)
85
86 # The test suite exercises all the loaders, so ensure they are all
87 # dependencies of the ptest package.
88 d.appendVar("RDEPENDS_gdk-pixbuf-ptest", " " + packages)
76} 89}
77 90
78do_install_append_class-native() { 91do_install_append_class-native() {