summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
new file mode 100644
index 0000000000..49a6023e54
--- /dev/null
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.24.1.bb
@@ -0,0 +1,82 @@
1DESCRIPTION = "Image loading library for GTK+"
2HOMEPAGE = "http://www.gtk.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
7 file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=5066b71daefeff678494fffa3040aba9"
8
9SECTION = "libs"
10
11DEPENDS = "libpng glib-2.0 jpeg"
12
13SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.24/gdk-pixbuf-${PV}.tar.xz \
14 file://configure_nm.patch \
15 file://hardcoded_libtool.patch \
16 file://configure_fix.patch \
17 "
18
19SRC_URI[md5sum] = "72f39b34b20f68148c1609bd27415412"
20#SRC_URI[sha256sum] = "da7a3f00db360913716368e19e336402755cafa93769f3cfa28a969303e4bee1"
21
22PR = "r0"
23
24inherit autotools pkgconfig gettext
25
26LIBV = "2.10.0"
27
28EXTRA_OECONF = "\
29 --without-libtiff \
30 --with-libpng \
31 --without-x11 \
32 --disable-introspection \
33"
34
35FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
36 ${libdir}/lib*.so.*"
37
38FILES_${PN}-dev += " \
39 ${bindir}/gdk-pixbuf-csource \
40 ${includedir}/* \
41 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \
42"
43
44FILES_${PN}-dbg += " \
45 ${libdir}/.debug/* \
46 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/.debug/* \
47"
48
49postinst_pixbufloader () {
50if [ "x$D" != "x" ]; then
51 exit 1
52fi
53
54GDK_PIXBUF_MODULEDIR=${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders gdk-pixbuf-query-loaders --update-cache
55
56test -x ${bindir}/gtk-update-icon-cache && gtk-update-icon-cache -q ${datadir}/icons/hicolor
57}
58
59PACKAGES_DYNAMIC += "gdk-pixbuf-loader-*"
60PACKAGES_DYNAMIC_virtclass-native = ""
61
62python populate_packages_prepend () {
63 postinst_pixbufloader = d.getVar("postinst_pixbufloader", True)
64
65 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders')
66
67 do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', postinst_pixbufloader)
68}
69
70do_install_append_virtclass-native() {
71#Use wrapper script rather than binary as required libtool library is not installed now
72 GDK_PIXBUF_MODULEDIR=${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders ${S}/gdk-pixbuf/gdk-pixbuf-query-loaders > ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
73 sed -i -e 's#${D}##g' ${D}${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
74 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
75
76 create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \
77 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
78
79 create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \
80 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
81}
82BBCLASSEXTEND = "native"