summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gcr/gcr_3.38.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gcr/gcr_3.38.1.bb')
-rw-r--r--meta/recipes-gnome/gcr/gcr_3.38.1.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta/recipes-gnome/gcr/gcr_3.38.1.bb b/meta/recipes-gnome/gcr/gcr_3.38.1.bb
deleted file mode 100644
index fe80439b00..0000000000
--- a/meta/recipes-gnome/gcr/gcr_3.38.1.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1SUMMARY = "A library for bits of crypto UI and parsing etc"
2DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \
3accessing key stores. It also provides the viewer for crypto files on the \
4GNOME desktop."
5HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr"
6BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
10
11DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt gnupg-native \
12 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
13
14CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'"
15
16GNOMEBASEBUILDCLASS = "meson"
17GTKDOC_MESON_OPTION = "gtk_doc"
18inherit gnomebase gtk-icon-cache gtk-doc features_check upstream-version-is-even vala gobject-introspection gettext mime mime-xdg
19# depends on gtk+3, but also x11 through gtk+-x11
20REQUIRED_DISTRO_FEATURES = "x11"
21
22SRC_URI[archive.sha256sum] = "17fcaf9c4a93a65fb1c72b82643bb102c13344084687d5886ea66313868d9ec9"
23
24FILES_${PN} += " \
25 ${datadir}/dbus-1 \
26 ${datadir}/gcr-3 \
27"
28
29# http://errors.yoctoproject.org/Errors/Details/20229/
30ARM_INSTRUCTION_SET_armv4 = "arm"
31ARM_INSTRUCTION_SET_armv5 = "arm"
32ARM_INSTRUCTION_SET_armv6 = "arm"
33
34EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross"
35do_write_config_append() {
36 cat >${WORKDIR}/meson-${PN}.cross <<EOF
37[binaries]
38gpg2 = '${bindir}/gpg2'
39EOF
40}