summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gcr/gcr_3.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gcr/gcr_3.20.0.bb')
-rw-r--r--meta/recipes-gnome/gcr/gcr_3.20.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gcr/gcr_3.20.0.bb b/meta/recipes-gnome/gcr/gcr_3.20.0.bb
new file mode 100644
index 0000000000..bcce57d586
--- /dev/null
+++ b/meta/recipes-gnome/gcr/gcr_3.20.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A library for bits of crypto UI and parsing etc"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
7
8DEPENDS = "intltool-native gtk+3 p11-kit glib-2.0 libgcrypt"
9
10inherit autotools gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
11# depends on gtk+3, but also x11 through gtk+-x11
12REQUIRED_DISTRO_FEATURES = "x11"
13
14SRC_URI[archive.md5sum] = "4314bf89eac293dd0a9d806593ff1b35"
15SRC_URI[archive.sha256sum] = "90572c626d8a708225560c42b4421f7941315247fa1679d4ef569bde7f4bb379"
16
17FILES_${PN} += " \
18 ${datadir}/dbus-1 \
19 ${datadir}/gcr-3 \
20"
21
22# http://errors.yoctoproject.org/Errors/Details/20229/
23ARM_INSTRUCTION_SET = "arm"
24
25# on x86-64 the introspection binary goes into
26# an infinite loop under qemu during compilation,
27# printing the following:
28#
29# gcrypt-Message: select() error: Bad address
30#
31# gcrypt-Message: select() error: Bad address
32#
33# gcrypt-Message: select() error: Bad address
34#
35# This will be investigated later.
36EXTRA_OECONF_append_x86-64 = " --disable-introspection"
37
38# Gcr-3.broken: poky/build-mips64/tmp/work/mips64-poky-linux/libgpg-error/1.19-r0/libgpg-error-1.19/src/posix-lock.c:119: get_lock_object: Assertion `!"sizeof lock obj"' failed.
39# qemu: uncaught target signal 6 (Aborted) - core dumped
40EXTRA_OECONF_append_mips64 = " --disable-introspection"