summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/xinetd/xinetd_2.3.15.bb')
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.15.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.15.bb b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
new file mode 100644
index 0000000000..1928949e94
--- /dev/null
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.15.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "http://www.xinetd.org"
3
4# xinetd is a BSD-like license
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
8
9DEPENDS = ""
10PR = "r2"
11
12SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
13 file://xinetd.init \
14 file://xinetd.conf \
15 file://xinetd.default \
16 file://Various-fixes-from-the-previous-maintainer.patch \
17 file://Disable-services-from-inetd.conf-if-a-service-with-t.patch \
18 file://xinetd-should-be-able-to-listen-on-IPv6-even-in-ine.patch \
19 file://xinetd-CVE-2013-4342.patch \
20 "
21
22SRC_URI[md5sum] = "77358478fd58efa6366accae99b8b04c"
23SRC_URI[sha256sum] = "bf4e060411c75605e4dcbdf2ac57c6bd9e1904470a2f91e01ba31b50a80a5be3"
24
25inherit autotools update-rc.d
26
27INITSCRIPT_NAME = "xinetd"
28INITSCRIPT_PARAMS = "defaults"
29
30EXTRA_OECONF="--disable-nls"
31
32PACKAGECONFIG ??= "tcp-wrappers"
33PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
34
35do_configure() {
36 # Looks like configure.in is broken, so we are skipping
37 # rebuilding configure and are just using the shipped one
38 ( cd ${S}; gnu-configize --force )
39 oe_runconf
40}
41
42do_install() {
43 # Same here, the Makefile does some really stupid things,
44 # but since we only want two files why not override
45 # do_install from autotools and doing it ourselfs?
46 install -d "${D}${sbindir}"
47 install -d "${D}${sysconfdir}/init.d"
48 install -d "${D}${sysconfdir}/xinetd.d"
49 install -d "${D}${sysconfdir}/default"
50 install -m 644 "${WORKDIR}/xinetd.conf" "${D}${sysconfdir}"
51 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
52 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
53 install -m 755 "${B}/xinetd/xinetd" "${D}${sbindir}"
54 install -m 755 "${B}/xinetd/itox" "${D}${sbindir}"
55}
56
57CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"