summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xinetd/xinetd_2.3.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/xinetd/xinetd_2.3.14.bb')
-rw-r--r--meta/recipes-extended/xinetd/xinetd_2.3.14.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/xinetd/xinetd_2.3.14.bb b/meta/recipes-extended/xinetd/xinetd_2.3.14.bb
new file mode 100644
index 0000000000..122be2c18d
--- /dev/null
+++ b/meta/recipes-extended/xinetd/xinetd_2.3.14.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "Highly configurable, modular and secure inetd"
2HOMEPAGE = "http://www.xinetd.org"
3
4# xinetd is a BSD-like license
5LICENSE = "xinetd"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8ad8615198542444f84d28a6cf226dd8"
7
8DEPENDS = ""
9PR ="r0"
10
11SRC_URI = "http://www.xinetd.org/xinetd-${PV}.tar.gz \
12 file://xinetd.init \
13 file://xinetd.conf \
14 file://Various-fixes-from-the-previous-maintainer.patch \
15 file://Disable-services-from-inetd.conf-if-a-service-with-t.patch \
16 file://xinetd-should-be-able-to-listen-on-IPv6-even-in-ine.patch \
17 "
18
19inherit autotools update-rc.d
20
21INITSCRIPT_NAME = "xinetd"
22INITSCRIPT_PARAMS = "defaults"
23
24EXTRA_OECONF="--disable-nls"
25
26do_configure() {
27 # Looks like configure.in is broken, so we are skipping
28 # rebuilding configure and are just using the shipped one
29 oe_runconf
30}
31
32do_install() {
33 # Same here, the Makefile does some really stupid things,
34 # but since we only want two files why not override
35 # do_install from autotools and doing it ourselfs?
36 install -d "${D}/usr/sbin"
37 install -d "${D}/etc/init.d"
38 install -d "${D}/etc/xinetd.d"
39 install -m 644 "${WORKDIR}/xinetd.conf" "${D}/etc"
40 install -m 755 "${WORKDIR}/xinetd.init" "${D}/etc/init.d/xinetd"
41 install -m 755 "${S}/xinetd/xinetd" "${D}/usr/sbin"
42 install -m 755 "${S}/xinetd/itox" "${D}/usr/sbin"
43}
44
45CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"