summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/which/which_2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/which/which_2.20.bb')
-rw-r--r--meta/recipes-extended/which/which_2.20.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/which/which_2.20.bb b/meta/recipes-extended/which/which_2.20.bb
new file mode 100644
index 0000000000..b7730de3b3
--- /dev/null
+++ b/meta/recipes-extended/which/which_2.20.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "which - shows the full path of (shell) commands."
2SECTION = "libs"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
5 file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
6HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
7DEPENDS = "cwautomacros-native"
8
9inherit autotools
10
11PR = "r0"
12
13SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
14 file://remove-declaration.patch"
15
16do_configure_prepend() {
17 sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
18}
19
20do_install() {
21 autotools_do_install
22 mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
23}
24
25pkg_postinst_${PN} () {
26 if [ "${PN}" = "${BPN}" ] ; then
27 update-alternatives --install ${bindir}/which which which.${PN} 100
28 fi
29}
30
31pkg_prerm_${PN} () {
32 if [ "${PN}" = "${BPN}" ] ; then
33 update-alternatives --remove which which.${PN}
34 fi
35}