diff options
Diffstat (limited to 'meta/recipes-extended/which/which_2.18.bb')
-rw-r--r-- | meta/recipes-extended/which/which_2.18.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/which/which_2.18.bb b/meta/recipes-extended/which/which_2.18.bb new file mode 100644 index 0000000000..b177949788 --- /dev/null +++ b/meta/recipes-extended/which/which_2.18.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "Which is a utility that prints out the full path of the \ | ||
2 | executables that bash(1) would execute when the passed \ | ||
3 | program names would have been entered on the shell prompt. \ | ||
4 | It does this by using the exact same algorithm as bash." | ||
5 | HOMEPAGE = "http://www.xs4all.nl/~carlo17/which/" | ||
6 | BUGTRACKER = "n/a" | ||
7 | |||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
10 | |||
11 | PR = "r0" | ||
12 | |||
13 | SRC_URI = "http://www.xs4all.nl/~carlo17/which/which-${PV}.tar.gz \ | ||
14 | file://fix_name_conflict_group_member.patch" | ||
15 | |||
16 | DEPENDS = "cwautomacros-native" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | do_configure_prepend() { | ||
21 | OLD="@ACLOCAL_CWFLAGS@" | ||
22 | NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4" | ||
23 | sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}` | ||
24 | } | ||
25 | do_install_append() { | ||
26 | mv ${D}/${bindir}/which ${D}/${bindir}/which.${PN} | ||
27 | } | ||
28 | |||
29 | pkg_postinst_${PN}() { | ||
30 | if [ "${PN}" = "${BPN}" ] ; then | ||
31 | update-alternatives --install ${bindir}/which which which.${PN} 100 | ||
32 | fi | ||
33 | } | ||
34 | |||
35 | pkg_prerm_${PN}() { | ||
36 | if [ "${PN}" = "${BPN}" ] ; then | ||
37 | update-alternatives --remove which which.${PN} | ||
38 | fi | ||
39 | } | ||
40 | |||